Closed Bug 653988 Opened 9 years ago Closed 9 years ago

I can't reopen old bugs even though I have editbugs

Categories

(bugzilla.mozilla.org :: General, defect)

Production
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 653231

People

(Reporter: jruderman, Unassigned)

References

Details

(Keywords: regression)

I can't reopen bug 411894 :(

The fix in bug 649625 was only supposed to affect Bugzilla users without editbugs.
OS: Mac OS X → All
Hardware: x86 → All
Let's discuss this in bug 653231 rather than tracking multiple bugs. FWIW, the original bug report for this change is bug 649625.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653231
There are two problems here. If you want to fix them both with one patch, that's great, but that doesn't make this bug report a dup.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
There was a brief suggestion to make this restriction only apply to people who don't have editbugs, and then it was realised that people with editbugs can't reopen bugs anyway (unless they are the reporter) and so that would make the restriction pointless.

Bug 653231 has an alternative suggestion to try and distinguish wrong reopenings from valid ones.

Gerv
Oh, I see. I was mislead by the title of the attachment in bug 649625 comment 13.
Given that the restriction was aimed at a "new user" mistake, it seems odd that it was redirected to users with editbugs at the last minute.
Yeah that was an error in that I didn't change the patch name properly. Sorry bout that. The latest patch just prohibits reopening of the bug regardless of 'editbugs' rights. I am getting ready to update 653231 with a patch that allows all except FIXED which I feel is sufficient.

dkl
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653231
You need to log in before you can comment on or make changes to this bug.