Query page falls over if product has no components.

RESOLVED FIXED in Bugzilla 2.14

Status

()

Bugzilla
Bugzilla-General
--
major
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: CodeMachine, Assigned: Tara Hernandez)

Tracking

unspecified
Bugzilla 2.14

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Naughty, naughty, someone wasn't looking for other instances of a bug when they
fixed it (bug #40987).  But then, I can't talk, as I verified the bug.

query.cgi should at least give a coherent error.  It should probably also
continue to work, but skip that product so the whole thing doesn't fall over
because of one product (do we have the ability to allow different groups access
to add components to different products?)

If it does work probably, we should probably emit a warning in mail, query.cgi,
the error log or something.

Should check all the .cgis in the product.  I'll try and get around to that
shortly.

Comment 1

17 years ago
Created attachment 23267 [details] [diff] [review]
fix for this bug and another one

Comment 2

17 years ago
the patch I submitted also fixes a syntax error in the js in the latest CVS 
version of query.cgi. Basically, somebody put an "if(... in ...)" in, which 
AFAIK is not supported by most browser - it certainly breaks my NS4.76 
(silently - the product/version/etc narrowing simply won't work) and my IE5.0 
(with a bang).

Updated

17 years ago
Keywords: patch
(Reporter)

Updated

17 years ago
Target Milestone: --- → Bugzilla 2.16
(Reporter)

Comment 3

17 years ago
*** Bug 81070 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

17 years ago
I know this wasn't considered a 2.12 blocker, but seriously folks, this problem
comes up so often it is really getting annoying, and I'm sick of explaining it
to people.

I vote for this as a 2.14 bug by nominating it as a "release blocker".  If I had
have known how serious it was I would have nominated it as a 2.12 blocker. 
We'll save the time spent fixing it back quickly.

We don't need to necessarily make the query page work, but we need to at least
make it say what the problem is.
Severity: minor → major
agreed.  But I'm not going to r= this patch.

I could swear those 'var' statements in the javascript were removed for a reason in another bug.  I forget the bug number though.  If this patch gets split into the component fixes for the specific bugs, I'll r= the fix for the component problem.
Keywords: patch
Target Milestone: Bugzilla 2.16 → Bugzilla 2.14
(Reporter)

Comment 6

17 years ago
*** Bug 74168 has been marked as a duplicate of this bug. ***
Keywords: patch, review
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
The component bug fix has been checked in.  The other chunk of the patch is not 
what was originally reported here, and it probably worth another bug if it's 
valid.

Comment 9

17 years ago
*** Bug 83351 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

17 years ago
*** Bug 71296 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

17 years ago
*** Bug 85438 has been marked as a duplicate of this bug. ***
Users upgrading to 2.12 and finding themselves unable to log in, may comment out 

use strict;

in query.cgi.  Then go look through your products and make sure each has at
least one component.  Then go back and uncomment it.

Comment 13

17 years ago
*** Bug 90620 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 14

17 years ago
*** Bug 97109 has been marked as a duplicate of this bug. ***
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
(Reporter)

Comment 16

17 years ago
*** Bug 98030 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 17

17 years ago
*** Bug 105466 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 18

17 years ago
*** Bug 106563 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.