Last Comment Bug 653997 - When using tab groups in FF4.0 - page titles prefixes (name of tab group) are mixed
: When using tab groups in FF4.0 - page titles prefixes (name of tab group) are...
Status: RESOLVED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: 4.0 Branch
: x86_64 Windows 7
: -- normal
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 682996
Blocks: 586556
  Show dependency treegraph
 
Reported: 2011-05-01 08:25 PDT by vladimir_sap
Modified: 2016-04-12 14:00 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
issue screenshot with anotation (80.96 KB, image/png)
2011-05-01 08:34 PDT, vladimir_sap
no flags Details

Description vladimir_sap 2011-05-01 08:25:09 PDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; tr; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729; .NET4.0E)

Test Case:
Prerequisites: Win7 64bit, with Aero turned on and also in Basic theme.
In FF4.0, create several tab groups and open a few tabs in each of the group.
Click on the FF icon on the task bar and watch closely the prefix to the page titles - which is the Tab Group name to which it belongs.

Expected Behavior:
Each page has a title prefix according to the tab group to which it belongs.

Observed Behavior:
See attached screenshot with annotations.
The page title prefixes (tab group names) are mixed between the pages, some are correct, some are not.
When you click on that page and it is maximized on the screen the page title prefix (tab group name) is the correct one. The problem is in the preview / list of the pages from the taskbar.

Reproducible: Always

Steps to Reproduce:
In FF4.0, create several tab groups and open a few tabs in each of the group.
Click on the FF icon on the task bar and watch closely the prefix to the page titles - which is the Tab Group name to which it belongs.

Actual Results:  
See attached screenshot with annotations.
The page title prefixes (tab group names) are mixed between the pages, some are correct, some are not.
When you click on that page and it is maximized on the screen the page title prefix (tab group name) is the correct one. The problem is in the preview / list of the pages from the taskbar.

Expected Results:  
Each page has a title prefix according to the tab group to which it belongs.


User Agent Switcher addon is used (to display some pages with FF3.6.8 compatabilty), however even when it is on default that happens too, so I don't think it is related.
Comment 1 vladimir_sap 2011-05-01 08:34:47 PDT
Created attachment 529356 [details]
issue screenshot with anotation
Comment 2 Tim Taubert [:ttaubert] 2011-05-16 04:38:35 PDT
Vladimir, did you try to reproduce this with all add-ons disabled or in safe-mode? Maybe anyone else on Windows can confirm?
Comment 3 vladimir_sap 2011-05-16 05:11:05 PDT
Hi, Tim,
I haven't tried to reproduce it with all add-ons disabled or in safe-mode.
Also another issue that could be related to that:
I'm using Win7 Basic theme mode (no Aero), and sometimes when hovering with my cursor over FF icon in the taskbar, it shows me a multitude of windows (for each window open in all my tab groups), but if I'd recently use the panorma button and go to one specific group, then it would show me only 1 icon/window. Aft4er a few alt-tabs to get back and forth to FF and switch between tabs, it goes back to displaying all the amount of windows I have open across all tab groups.

(In reply to comment #2)
> Vladimir, did you try to reproduce this with all add-ons disabled or in
> safe-mode? Maybe anyone else on Windows can confirm?
Comment 4 Tim Taubert [:ttaubert] 2011-10-18 14:13:13 PDT
Fixed by bug 682996.

Note You need to log in before you can comment on or make changes to this bug.