Update failure for 3.6.17 and crash of Foxfire thereafter

RESOLVED DUPLICATE of bug 466778

Status

()

Toolkit
Application Update
--
major
RESOLVED DUPLICATE of bug 466778
7 years ago
7 years ago

People

(Reporter: Ron Matelski, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET CLR 3.5.30729)
Build Identifier: Firefox update for 3.6.17

Firefox requested update of 3.6 (can't remember subversion probably 3.6.14 or .15) and upon execution of update, which downloaded without problem, update failed and subsequent run of Firefox failed due to bad "xul.dll" program. 

I used Windows Explorer and found "xul.dll" in Firefox folder to have 0 size.  Found "xul.dll.moz.backup" backup file and renamed it to "xul.dll".  Was able to startup Firefox and reload my prior session.  Firefox seemed to be running ok, but requested to update to 3.6.17 which I ran again.  Firefox update failed again and attempted several times with failure.  At this point Firefox didn't seem to be functioning properly.  Message said to manually download update from Mozilla website.  Your website doesn't have download available for 3.6 only 4.0  I've tried 4.0 and dislike it a lot with its reformatting of screens and functions.

I found an old hard drive copy of 3.6.0 and reinstalled this on top of the current Firefox which ran successfully.  Firefox ran properly but was sitting at version 3.6.0 so I ran update to 3.6.17 again.  This time update failed due to "update.exe" and I also received a Windows error on "update.exe" which was reported to MS.  After several attempts to run Firefox, a system backup copy of "update.exe" was found from 3/16/11 and restored (file size was 5 bytes smaller) and Firefox was restarted and it processed the update to 3.6.17

My Firefox is running at 3.6.17 without problem.  But you need to fix the update 3.6 process because I don't want to go thru this again

Reproducible: Always

Steps to Reproduce:
1. Run update for 3.6.17 on older version
2. Try to restart Firefox
3. See details above

Actual Results:  
See details above

Expected Results:  
Firefox should run

See details above
Component: Build Config → Application Update
Product: Firefox → Toolkit
QA Contact: build.config → application.update

Updated

7 years ago
Version: unspecified → 1.9.2 Branch
Very likely fixed by bug 466778 which changed the update process to use file renames vs. file copies and landed for Firefox 3.6.17 so resolving -> duplicate.

If this happens again when updating from 3.6.17 to Firefox 3.6.18 or greater or to a version of Firefox 4.0 please reopen or just add a comment to this bug to that affect and I'll reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466778
You need to log in before you can comment on or make changes to this bug.