[dev] Upgrade to a modern browser message displays briefly

VERIFIED FIXED in 1.0

Status

--
blocker
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: mbrandt, Assigned: adam)

Tracking

unspecified

Details

(Whiteboard: [dev], URL)

(Reporter)

Description

7 years ago
When loading the landing page the "Oops ..." please upgrade to a modern browser message displays for a brief period of time.  The behavior is more prominent with a cold cache however also occurs when the page is reloaded or subsequently revisisted. 

Browsers effected:
- OSX: Firefox 4.0.x, Chrome 11.x, Safari 5.0.5
- Win7: IE9

http://screencast.com/t/nadtAGb89

Steps to reproduce:
1. Clear the browsers cache
2. Go to staging url

Expected:
Supported browsers should not see the upgrade to a modern browser message.

Actual:
The upgrade message briefly renders on the screen before flickering off.
Assignee: nobody → adam
Blocks: 628811
(Assignee)

Comment 1

7 years ago
I've moved the code that removes the fallback content up so it's one of the first things executed when the page loads. Seems to have fixed this problem. 

https://github.com/mozilla/markup/commit/61239c23fdfc00db241f4d6ad2d3075f68837d23
(Reporter)

Comment 2

7 years ago
Bumping this to RESOLVED/FIXED, comment 1.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

7 years ago
Adam, what I'm seeing looks great so far! Thanks for the quick turn around on the patch! I want to play with a few more use cases before moving this to VERIFIED.
(Reporter)

Comment 4

7 years ago
Moving this to verified. QA completed a full regression and this is working great at this time.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

7 years ago
This bug is back in Firefox 4.0.1. The message to upgrade to a modern browser briefly displays on a cold cache when bandwidth is throttled to 1.5 mbps.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Summary: [stage] Upgrade to a modern browser message displays briefly → [dev] Upgrade to a modern browser message displays briefly
Whiteboard: [dev]
Severity: normal → blocker
Matt--can you describe how briefly?
 is it something that we can live with, or would you judge it to be a bad experience?
(Reporter)

Comment 7

7 years ago
The behavior is the same as in comment 0 (http://screencast.com/t/nadtAGb89).

This only occurs when the app is not already cached. Subsequent views of the webpages don't expose this defect. That said it doesn't speak well when the user briefly reads the message that their browser needs to be upgraded when they're already on FF 4.0.1. The message lingers on the screen for longer durations when on slow connections. Note I'm at a conference atm and bandwidth stinks and this is quite pronounced ;-)
I've seen this, but haven't been overly concerned about it.  It's not a blocker, but it should be taken care of because it does induce a temporary moment of confusion.
(Assignee)

Comment 9

7 years ago
Added a more serious solution involving a noscript tag and a fallback for the noscript. Check it out: 

https://github.com/mozilla/markup/commit/1db54c5b9663e887f892b06742b37fa3a2390c69
Keywords: qawanted
(In reply to comment #9)
> Added a more serious solution involving a noscript tag and a fallback for
> the noscript. Check it out: 
> 
> https://github.com/mozilla/markup/commit/
> 1db54c5b9663e887f892b06742b37fa3a2390c69

Anything left to do?  If not, please mark this as Resolved FIXED; thanks.
This works for me. I'll add fixed and ask matt to verify.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

7 years ago
Appears better again.
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.