Closed Bug 654230 Opened 9 years ago Closed 9 years ago

Dragging tab from a window into a different window appears to needlessly refresh the tab.

Categories

(Firefox :: Tabbed Browser, defect)

3.6 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 449734

People

(Reporter: hacksaw, Unassigned)

References

()

Details

(Whiteboard: [DUPEME?] 449734)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17

I had two windows open, one with a lot of tabs, the other with just one. I decided that was silly, so I grabbed the tab, and dragged it over to the window with a lot of tabs. When it landed, it reloaded the page. Given that it was an application (FB Scrabble), this means it took quite a while. More importantly, it was an astonishing action. I didn't want it to be reloaded. If I had been in the middle of filling out some form, I'd lose my state.

In general, reloading a screen ought to happen only by explicit request of the user. For example, hitting "back" shouldn't cause a reload if it can be avoided.

Reproducible: Always
Is this a flash game? If yes, this issue should have been fixed for Firefox 4 on bug 449734.
Whiteboard: [DUPEME?] 449734
Version: unspecified → 3.6 Branch
Please upgrade to a modern browser like Firefox 4.0.1 and see if you still can reproduce the bug.

http://www.mozilla.com/en-US/firefox/all.html


Works for me with:
Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
What release is this fix going into? 4.0.1 doesn't even run Scrabble. I'm not sure that's a problem in Mozilla, but you can see why this is a very disappointing answer.
The fix that handles the refresh problem got introduced in the Firefox 4 series in September 2010. To clarify my "Works for me" statement in comment 2, I verified that the functionality still is present in 4.0.1 in in the general case, not in FB Scrabble specifically. I do doubt there will be any back ports of this to lower versions.

The problem with Firefox 4 and FB Scrabble seems to be something completely different, probably not related to the refresh problem at all.
Yep, okay, marking as dupe of bug 449734
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449734
You need to log in before you can comment on or make changes to this bug.