Last Comment Bug 654463 - Remove WinCE & Windows Mobile code from content/*
: Remove WinCE & Windows Mobile code from content/*
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-03 09:29 PDT by Ed Morley [:emorley]
Modified: 2011-05-04 01:30 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from content/* (9.14 KB, patch)
2011-05-03 09:33 PDT, Ed Morley [:emorley]
jonas: review+
Details | Diff | Splinter Review
Remove WinCE code from content/* (9.15 KB, patch)
2011-05-03 18:11 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-05-03 09:29:16 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the content/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/content/
Comment 1 Ed Morley [:emorley] 2011-05-03 09:33:02 PDT
Created attachment 529737 [details] [diff] [review]
Remove WinCE code from content/*

Removes WinCE ifdefs from:

content/canvas/src/nsCanvasRenderingContext2D.cpp
content/svg/content/src/nsSVGFilters.cpp
content/xbl/builtin/Makefile.in
content/xslt/src/xslt/txEXSLTFunctions.cpp
Comment 2 Ed Morley [:emorley] 2011-05-03 15:48:14 PDT
Comment on attachment 529737 [details] [diff] [review]
Remove WinCE code from content/*

Passed try: http://dev.philringnalda.com/tbpl/?tree=Try&rev=0e42b10dba46
Comment 3 Ed Morley [:emorley] 2011-05-03 18:11:10 PDT
Created attachment 529910 [details] [diff] [review]
Remove WinCE code from content/*

Only change is updated commit message to include r=sicking

Carrying forwards r+
Comment 4 Dão Gottwald [:dao] 2011-05-04 01:30:39 PDT
http://hg.mozilla.org/mozilla-central/rev/3bae6630c5af

Note You need to log in before you can comment on or make changes to this bug.