Closed Bug 654468 Opened 10 years ago Closed 9 years ago

NSS 3.12.10 fails to build on OSX 64 bit

Categories

(NSPR :: NSPR, defect)

4.8.8
x86_64
macOS
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: KaiE, Assigned: wtc)

Details

Attachments

(1 file)

Attached file build failure
3.12.10 fails to build on OSX 64 bit

used NSS 3.12.10 beta 1 with NSPR 4.8.8 beta 3

Full log:

http://tinderbox.mozilla.org/showlog.cgi?log=Try/1304431222.1304439615.4465.gz&fulltext=1

Excerpt: see attachment.
Kai:

Please first try backing out the patch in NSPR bug 645459.  Note that you
also need to modify nsprpub/configure in the same way.  The patch
contains only nsprpub/configure.in and omits the nsprpub/configure
change.

If that doesn't fix the problem, then try *also* backing out the patch
in NSS bug 645460.
Details:

The full build log shows NSPR was configured twice, with these command lines:

running /bin/sh /builds/slave/try-osx64/build/nsprpub/configure  --target=i386-apple-darwin10.2.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.5.sdk --enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-tests --enable-codesighs --disable-install-strip --disable-auto-deps --enable-debug-symbols=-gdwarf-2 --with-dist-prefix=/builds/slave/try-osx64/build/obj-firefox/i386/dist --with-mozilla --disable-debug --enable-optimize --cache-file=.././config.cache --srcdir=/builds/slave/try-osx64/build/nsprpub

running /bin/sh /builds/slave/try-osx64/build/nsprpub/configure  --target=x86_64-apple-darwin10.2.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.6.sdk --enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-tests --enable-codesighs --disable-install-strip --disable-auto-deps --enable-debug-symbols=-gdwarf-2 --with-dist-prefix=/builds/slave/try-osx64/build/obj-firefox/x86_64/dist --with-mozilla --disable-debug --enable-optimize --enable-64bit --cache-file=.././config.cache --srcdir=/builds/slave/try-osx64/build/nsprpub

The first one resulted in the compiler command:
    gcc-4.2 -arch i386 -arch i386
This is not ideal but acceptable.

The second one resulted in the compiler command:
    gcc-4.2 -arch x86_64 -arch ppc
This is wrong because it generates a "fat" binary unexpectedly.

I can improve the patch in NSPR bug 645459 to handle this properly,
but for NSPR 4.8.8 it's simpler to just exclude that patch.
Thanks. I've started a tryserver build with the first patch backed out. The queue is quite big, it will take a couple of hours until we see the results.
First test failed.
Sigh. I should have pushed both tests at the same time. Thought I'd save unnecessary load on the build slaves...

Second build running, with second bug backed out...
(In reply to comment #4)
> First test failed.
> Sigh. I should have pushed both tests at the same time. Thought I'd save
> unnecessary load on the build slaves...
> 
> Second build running, with second bug backed out...

FYI
http://tinderbox.mozilla.org/showlog.cgi?log=Try/1304446104.1304455422.19265.gz&fulltext=1
On the other hand, with the NSPR patch backed out, we should no longer see a failure in libnspr4, right? Rather, the expected failure would be something in NSS, right?

So, if we still get a failure in NSPR, does that mean Wan-Teh's suspicion (bug 645459) is wrong?
Kai: I believe you didn't back out the NSPR patch correctly.  Please read
my instructions in comment 1 carefully, including the "Note".
(In reply to comment #7)
> Kai: I believe you didn't back out the NSPR patch correctly.  Please read
> my instructions in comment 1 carefully, including the "Note".

Sigh. You're right.
I confirm it is sufficient to backout bug 645459.

It works to keep 645460.
This turned out to be a regression of an NSPR patch.
The patch has been backed out.
Assignee: nobody → wtc
Status: NEW → RESOLVED
Closed: 9 years ago
Component: Libraries → NSPR
Product: NSS → NSPR
QA Contact: libraries → nspr
Resolution: --- → FIXED
Summary: 3.12.10 fails to build on OSX 64 bit → NSS 3.12.10 fails to build on OSX 64 bit
Target Milestone: 3.12.10 → 4.8.8
Version: 3.12.10 → 4.8.8
You need to log in before you can comment on or make changes to this bug.