Last Comment Bug 654504 - Remove WinCE & Windows Mobile code from dom/plugins/base/
: Remove WinCE & Windows Mobile code from dom/plugins/base/
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-03 11:09 PDT by Ed Morley [:emorley]
Modified: 2011-07-29 07:14 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from dom/plugins/base/ (13.77 KB, patch)
2011-05-03 11:24 PDT, Ed Morley [:emorley]
jaas: review+
Details | Diff | Splinter Review
Remove WinCE code from dom/plugins/base/ (13.77 KB, patch)
2011-05-08 04:02 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-05-03 11:09:25 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the dom/plugins/base/* parts of the removal; since the folder was moved to dom/ only after the initial WinCE removal patch in bug 651657.

http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/dom/plugins/base/
Comment 1 Ed Morley [:emorley] 2011-05-03 11:24:27 PDT
Created attachment 529771 [details] [diff] [review]
Remove WinCE code from dom/plugins/base/
Comment 2 Ed Morley [:emorley] 2011-05-04 05:34:33 PDT
Comment on attachment 529771 [details] [diff] [review]
Remove WinCE code from dom/plugins/base/

Passed try: http://dev.philringnalda.com/tbpl/?tree=Try&rev=357126c2abd1
Comment 3 Ed Morley [:emorley] 2011-05-08 04:02:26 PDT
Created attachment 530904 [details] [diff] [review]
Remove WinCE code from dom/plugins/base/

Only change is updated commit message to include r=josh
Carrying forwards r+
Comment 4 Ed Morley [:emorley] 2011-05-11 08:41:56 PDT
http://hg.mozilla.org/mozilla-central/rev/6de561136bc9
Comment 5 AndreiD[QA] 2011-07-29 07:14:53 PDT
Build ID: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

The changes made in m-c and landed (comment 4) are visible in hg, under beta (i.e. code removal referring to WindowsCE in nsNPAPIPlugin.cpp).
Setting this as verified for Firefox 6 Beta

Note You need to log in before you can comment on or make changes to this bug.