bgcolor height=div height and not visible height

RESOLVED INVALID

Status

()

RESOLVED INVALID
18 years ago
18 years ago

People

(Reporter: hojani, Assigned: clayton)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

569 bytes, text/html
Details
(Reporter)

Description

18 years ago
<div id="div1" style="height:10;background-color:blue;">
1.line<br>
2.line
</div>

When i set the height of a div element but nothing else (like overflow, clip, 
etc) the background color's height is only = with this value and not with the 
visible content height.
(Reporter)

Comment 1

18 years ago
Created attachment 22573 [details]
testcase
I believe that this is the correct CSS2 behavior.  The background color is only
applied to the content area of the div.  asking Hixie to take a look at this,
just in case.
QA Contact: petersen → ian
Summary: bgcolor height=div height and not visible height → bgcolor height=div height and not visible height
it's correct per CSS2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
since i resolved it, i can't verify it...
QA Contact: ian → petersen
You need to log in before you can comment on or make changes to this bug.