Editor performance details does not update

VERIFIED FIXED in 6.0.9

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: gkoberger)

Tracking

unspecified
6.0.9

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 529886 [details]
screenshot

steps to reproduce:
1. I have reviewed 3 add-ons in the last two days from the account "kr raj". See https://addons-next.allizom.org/en-US/editors/reviewlog
2. Load https://addons-next.allizom.org/en-US/editors/performance


expected behavior:
My reviews section lists '3'

observed behavior:
My reviews section shows '0'. See screenshot
(Assignee)

Updated

7 years ago
Assignee: nobody → gkoberger
what's the news on this?
(Assignee)

Comment 2

7 years ago
Currently testing my patch to make sure it works.
(Assignee)

Comment 3

7 years ago
https://github.com/jbalogh/zamboni/commit/3d46c6cf111d4108f61a8da193e162e96d43d0a4

On next, the numbers will be slightly off from preview, since andym caught a small bug after I had landed it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
The graph doesn't update when I review add-ons.

Compare the info @ https://addons.allizom.org/en-US/editors/reviewlog to https://addons.allizom.org/en-US/editors/performance

There are 10+ add-on reviews in May. Performance page just shows 2

Reopening..
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 6.0.8 → 6.0.9
(Reporter)

Comment 5

7 years ago
So, reviews done from my admin account are not getting counted.
(Assignee)

Comment 6

7 years ago
https://github.com/jbalogh/zamboni/commit/0137d
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

7 years ago
We update the review count when the editor chooses 'Request more information' and 'Request super-review' options. This means that the same add-on will be counted multiple times. Is that okay?
(Assignee)

Comment 8

7 years ago
I asked Jorge, and he said that's the way it should work.  If we want to change it, you can file a bug to group it by add-on ID, so each add-on only shows up once.
(Reporter)

Comment 9

7 years ago
If jorgev is happy, I'm happy.

verified fixed @ https://addons.allizom.org/en-US/editors/performance

Checked with accounts with 'editor' and 'admin' prevs. verified that all editor actions are logged for all review queues.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.