The backspace key doesn't delete text entered in Persian after switching to English PC language

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: doctorcomedian, Unassigned)

Tracking

4.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20110513])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: FireFox 4 Last Version

Hi,
when my pc lacguage is persian then I Write 0ne word in firefox then change my pc language to english and tab The backspace key to delete that one persian word firefox dosnt work and dont delete that.
please fix this problem. 
sorry about my english.

Reproducible: Always
Is your Issue reproducible without Extensions in Safe-Mode and/or using a new Profile?
https://support.mozilla.com/en-US/kb/Safe+Mode
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile
Version: unspecified → 4.0 Branch

Comment 2

7 years ago
Works for me with an English Window XP SP3. 
Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110513 Firefox/6.0a

My Steps to Reproduce:

1. Install language support for Farsi
2  Select Farsi keyboard
3. Type some letters (I tested with qwerty, but also random ones).
4. Select English (United States) keyboard
5. Press Backspace multiple times

Step 5 deleted the letters I just had entered.

I successfully tested this both in for example the Google text box on the about:home page and in the address bar - and everything worked for me.
Whiteboard: [bugday-20110513]

Comment 3

7 years ago
Elyas, have you tried the things suggested in comment 1?

Updated

7 years ago
Summary: problem with changing language → The backspace key doesn't delete text entered in Persian after switching to English PC language

Comment 4

7 years ago
Elyas, is the problem is this bug still an issue for you while running recent versions of Firefox?
(Reporter)

Comment 5

7 years ago
(In reply to Thomas Ahlblom from comment #4)
> Elyas, is the problem is this bug still an issue for you while running
> recent versions of Firefox?

no, the problem is solved.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.