Big memory leak when I download the list of all the newsgroups from my server (Build 2001010901)

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Ernesto Manríquez, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2001010901

I have a good news provider, with over 30.000 newsgroups connected to it. When 
I opened the Mozilla Mail/News Component, and downloaded all the newsgroups, 
Mozilla started to be less responsive, and the news client nearly hanged itself 
when I was opening a message of the newsgroups. Later, I closed the Mail/News 
Component and Mozilla continued to be less responsive, this time in the 
browser. I opened the NT Task Manager, and I saw that Mozilla's size in memory 
was 40.097 KB (39MB). I attributed this to a memory leak when loading a single 
newsgroup into memory.

Reproducible: Didn't try
Steps to Reproduce:
This is what I did to discover the bug.

1. I installed Mozilla (0.7, over 0.6, and having uninstalled completely 0.6).
2. I opened Mozilla.
3. I went to the Mail/News Component.
4. I clicked with the right button on my news server and selected "Suscribe". 
Mozilla started to download the newsgroups.
5. When Mozilla sorted the newsgroups into a tree, and showed them to me, the 
bug showed itself.

Actual Results:  The Mozilla's response was lagged by seconds, and the Mozilla 
size in memory was over 39MB.

Expected Results:  Mozilla must show the newsgroups, and later it must allow me 
to scroll the newsgroups at normal speed (not lagged by seconds). When I close 
the "Subscribe" box, Mozilla must clean all the memory of the list.

I think Mozilla's branch display of newsgroups is a waste of time, and memory. 
I think Moziila simply must display me all the groups, and later allow me to 
search by topic, like Outlook Express.

Comment 1

18 years ago
It works fine for me on my local isp server and on news.mozilla.org. I am
guessing yours is reaaaaly huge, and it's a problem with the tree widget (a
general problem, mind, not just for that dialog). Adding stephend to CC.
I'll investigate, this might get resolved a DUP of one of our PERF bugs in bug
63759.
QA Contact: esther → stephend
The search by description is covered in bug 37775.  We have a known problem
launching the subscribe window the 2nd time in Bug 61537.  Scrolling is good for
me, although if you do anything with the alt* hiarchy, we start to get really
slow, that's bug 62985.  And last, but not least, we have bug 63759, which
tracks all of our news/mail performance problems.  Ernesto, thanks for filing,
in the future however, please limit each bug report to a single
suggestion/problem.  Thanks!

Comment 4

18 years ago
Marking this as a duplicate of bug 26131.

*** This bug has been marked as a duplicate of 26131 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
re-opening until I can find the proper bug to dup this to.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Comfirmed, Windows 2k same build.

I downloaded a little over 40,000 newsgroups and the afterwards, the dialog 
lags a little bit when expanding a lot of large branches. When I clicked on 
the "alt" twisty (as in alt.binaries), it really lagged (took forever to open). 
After I expanded "alt", it said in my Windows 2000 Task manager that Mozilla 
takes up 38 megs of ram. I never tried "alt.binaries". After I closed the 
dialog, the mem leak seemed to stay since the mem usage didn't drop in the task 
manager. After I closed the Mozilla browser and mailnews, the Mozilla task 
stayed open for a while. 
Dupe of bug 54491? Subscribe dialog, slow, 100% CPU, mega bloat (23 MB to 88 
MB), leaks
I haven't seen 100% CPU on the subscribe dialog, so I'd have to say no dup.  I'm
not sure it's easy to seperate news leaking from the mail app in general, until
a Purify session is run against news.
Status: UNCONFIRMED → NEW
Ever confirmed: true
can someone do this:

1) start application, launch mail.  determine how much memory is used.
2) launch subscribe, wait until it is all done. determine how much memory is
used.
3) close subscribe. determine how much memory is used.

those will tell me if we are leaking, if we are using too much memory at the
peak, etc.
I used a two day old build for this, I don't believe anything has changed enough
to warrant a new one (I am dual booting, this was done in Win2K, I normally use
NT 4.0).  I used CTRL-ALT-DLT to bring up the standard Windows 2000 task
manager, to check the usage stats.  Here are my results:

Before mail, I had *69550k in use.  18 processes running.*
Fired up mail with netscp6.exe -mail.  
*Now had 84420K, and 20 processes.*
Launched the subscribe window.
*Now had 86440K and 20 processes*
Closed the subscribe window.
Still had *85704K and 20 processes*
Closed the whole Mail app and had:
*18 processes and 69684K*.
Build 2001011904. Win2k.

Mem usage: 209832K

Start Mozilla.

Mem usage: 222780K
Mozilla: 18320K

Start Mailnews.

Mem usage: 226340K
Mozilla: 22724K

Create News account (news.erols.com) in Account Settings.

Mem usage: 229144K
Mozilla: 25640K

Close Account Settings. 

same.

Subscribe opened (42000+ groups downloaded).

Mem usage: 237534K
Mozilla: 33884K

Navigate to "Alt" (click on twisty)

Results: Very slow to open tree. (~10 seconds)

Mem Usage: 244344K
Mozilla: 38772K

Click on "binaries" twisty

Mem Usage: 246348K
Mozilla: 40824K

Subscribe to Alt.binaries.autos.performance-cars

Same

Close Subscribe. (Click OK)

Mem Usage: 242744K
Mozilla: 37352K

Thats a 4 meg difference from when opened to when closed.

Closed MailNews.

Mem Usage: 242452K
Mozilla: 37024K

Same as before closed. 

Close Mozilla.

Mem Usage: 237204K
Mozilla: 35268K

Mozilla still on Task list 5 min. later

End Process Mozilla.

Mem Usage: 209124K
Mozilla: None









 

Doesn't look like a huge memory leak to me, Seth, comments?
Ernesto, can you follow the same procedure as I did, and report your finding? 
Slow and memory leaks can be two seperate things, thanks!
Okay, if you look at my finding in this post:

------- Additional Comments From stephend@netscape.com 2001-01-19 17:44 -------

You'll see that when I closed the subscribe dialog, memory usage went down by
about a meg.  Yet when I closed the mail window in general, it went down by
about 15 megs.  So, I'd say this is the whole mail window's usage, and not the
subscribe window's.

Seth, please share your view here (I'm not sure what is considered "leak" if
it's a meg or higher?)

Comment 16

18 years ago
I don't see a memory leak here.  030608 mozilla builds.
marking worksforme.  my finding don't indicate a serious leak.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.