Closed Bug 654736 Opened 9 years ago Closed 9 years ago

Remove WinCE code from XULRunner

Categories

(Toolkit Graveyard :: XULRunner, defect)

All
Windows CE
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla6

People

(Reporter: emorley, Assigned: emorley)

References

Details

Attachments

(1 file, 1 obsolete file)

WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the xulrunner/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/xulrunner/
Attached patch Remove WinCE code from XULRunner (obsolete) — Splinter Review
Assignee: nobody → bmo
Status: NEW → ASSIGNED
Comment on attachment 530074 [details] [diff] [review]
Remove WinCE code from XULRunner

These changes look safe to me
Attachment #530074 - Flags: review+
Only change is updated commit message to include r=mfinkle
Carrying forwards r+

Thanks for the fast review Mark! :-)

Passed try:
http://dev.philringnalda.com/tbpl/?tree=Try&rev=ed18eff9dd9a
Attachment #530074 - Attachment is obsolete: true
Attachment #530202 - Flags: review+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/c169c3b8dfb2

Thanks Matt :-)
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla6
Backed out because something that landed with this caused a new orange (Win debug Moth tabview/browser_tabview_bug597248.js):
http://hg.mozilla.org/mozilla-central/rev/eaaa24ff93a0

This can probably land again once we figure out the cause of the test failures.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
re-landed: http://hg.mozilla.org/mozilla-central/rev/192bc9af9a0d
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.