[Traceback] UnicodeEncodeError: 'ascii' codec can't encode character u'\u0131' in position 25: ordinal not in range(128)

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: retornam, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
File "/data/www/django/spark.mozilla.org/spark_site/vendor/src/django/django/core/handlers/base.py", line 100, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/django/spark.mozilla.org/spark_site/apps/spark/decorators.py", line 43, in _checkssl
   return view_func(request, *args, **kwargs)

 File "/data/www/django/spark.mozilla.org/spark_site/apps/spark/decorators.py", line 83, in _wrapped_view
   return view_fn(request, *args, **kwargs)

 File "/data/www/django/spark.mozilla.org/spark_site/vendor/src/django/django/views/decorators/http.py", line 37, in inner
   return func(request, *args, **kwargs)

 File "/data/www/django/spark.mozilla.org/spark_site/apps/spark/decorators.py", line 146, in wrapper
   response = f(*args, **kw)

 File "/data/www/django/spark.mozilla.org/spark_site/apps/users/views.py", line 90, in register
   form = handle_register(request)

 File "/data/www/django/spark.mozilla.org/spark_site/apps/users/utils.py", line 38, in handle_register
   new_user = User.objects.create_user(username, email, password)

 File "/data/www/django/spark.mozilla.org/spark_site/vendor/src/django/django/contrib/auth/models.py", line 124, in create_user
   user.set_password(password)

 File "/data/www/django/spark.mozilla.org/spark_site/vendor/src/django-sha2/django_sha2/auth.py", line 60, in set_password
   hsh = get_hexdigest(algo, salt, raw_password)

 File "/data/www/django/spark.mozilla.org/spark_site/vendor/src/django-sha2/django_sha2/auth.py", line 49, in get_hexdigest
   return getattr(hashlib, algorithm)(salt + raw_password).hexdigest()

UnicodeEncodeError: 'ascii' codec can't encode character u'\u0131' in position 25: ordinal not in range(128)
Related to/duplicate of bug 654569?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Related to/duplicate of bug 654569?

Urls are different.
(In reply to comment #2)
> (In reply to comment #1)
> > Related to/duplicate of bug 654569?
> 
> Urls are different.

Yes, but the call stacks aren't -- anyway, Franck is best-able to determine.

Comment 4

7 years ago
It's related but might require a different fix, so we should keep them
separate for now I think.
Spark is now over.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.