can not use javascript expressions as HTML attribute values

VERIFIED DUPLICATE of bug 65475

Status

()

VERIFIED DUPLICATE of bug 65475
18 years ago
17 years ago

People

(Reporter: ipottinger, Assigned: rogerl)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001229
BuildID:    2000122904

Mozilla does not allow you to specify a javascript expression as the value of an
HTML attribute using the format: &{expression};   This javascript feature is
described in detail at the URL specified above.

Reproducible: Always
Steps to Reproduce:
1) save the HTML code provided below to a file.
2) open the file in Mozilla's browser.

Actual Results:  Mozilla displays the line of text: "The line below should be
50% of the width of the screen" above a horizontal ruler with an apparent width
of 100% that of the screen's.

Expected Results:  Mozilla should displays the line of text: "The line below
should be 50% of the width of the screen" above a horizontal ruler with a width
of 50% that of the screen's.


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
  <title>test</title>
  <script language = 'javascript'> barWidth = 50; </script>
</head>
<body>
  The line below should be 50% of the width of the screen<br/>
  <hr width='&{barWidth};%' align='LEFT'/>
</body>
</html>

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 65475 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
submitted twice - verif.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.