Closed Bug 654798 Opened 11 years ago Closed 11 years ago

Fennec browser chrome tests install to the wrong place

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 6

People

(Reporter: stechz, Assigned: stechz)

References

Details

Attachments

(1 file, 1 obsolete file)

They are installed to mobile/chrome/ instead of mobile/chrome/tests.
Attachment #530114 - Flags: review?(mark.finkle)
Comment on attachment 530114 [details] [diff] [review]
Fennec browser chrome tests install to the wrong place

let's get Joel's opinion on whether this will somehow break maemo or android packaging of tests.
Attachment #530114 - Flags: review?(mark.finkle)
Attachment #530114 - Flags: review?(jmaher)
Attachment #530114 - Flags: review+
Comment on attachment 530114 [details] [diff] [review]
Fennec browser chrome tests install to the wrong place

Review of attachment 530114 [details] [diff] [review]:

this should work just fine on android/maemo.  We run the tests with '--test-path=mobile', so it doesn't matter what the subdirectories look like.

Good catch!
Attachment #530114 - Flags: review?(jmaher) → review+
Fixed more hard-coded paths, removing them where I could.
Attachment #530124 - Flags: review?(jmaher)
Attachment #530114 - Attachment is obsolete: true
Assignee: nobody → ben
Blocks: 521113
Comment on attachment 530124 [details] [diff] [review]
Fennec browser chrome tests install to the wrong place

Review of attachment 530124 [details] [diff] [review]:

thanks for the cleanup!
Attachment #530124 - Flags: review?(jmaher) → review+
Pushed http://hg.mozilla.org/mozilla-central/rev/1defe29fdf3c
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 6
Backed out because something that landed with this caused a new orange (Win debug Moth tabview/browser_tabview_bug597248.js):
http://hg.mozilla.org/mozilla-central/rev/eaaa24ff93a0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
re-landed: http://hg.mozilla.org/mozilla-central/rev/ccbde21853b1
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Can someone please verify this bug or provide some steps to reproduce?
Verified This was just a code movement no tests sitting in http://hg.mozilla.org/mozilla-central/file/f584467626df/mobile/chrome atm.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.