[QAC generated] url color no longer changes properly with theme

VERIFIED FIXED in Firefox 7

Status

()

Firefox
General
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Jonathan, Unassigned)

Tracking

Trunk
Firefox 7
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 654411][bugday-20110513])

(Reporter)

Description

6 years ago
Steps to Reproduce
---------------------------------------
1. Download a theme that changes the url color
2. Type in a url and go to it
3. watch the URL bar

What should have happened:
---------------------------------------
If the theme has a set URL text color then the entire url text should change color



What actually happened:
----------------------------------------
the "http://www" part of the url as well as the trailing "/" does not change.

Comment 1

6 years ago
I guess this is probably caused by:
Bug 451833 - Highlight the domain name in the address bar
FWIW this is a known bug.
Blocks: 451833

Comment 3

6 years ago
(In reply to comment #2)
> FWIW this is a known bug.
Any bug to dupe against?
Whiteboard: [bugday-20110513][dupeme]

Updated

6 years ago
Depends on: 654411

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [bugday-20110513][dupeme] → [fixed by bug 654809][bugday-20110513][dupeme]
Target Milestone: --- → Firefox 7

Updated

6 years ago
Whiteboard: [fixed by bug 654809][bugday-20110513][dupeme] → [fixed by bug 654809][bugday-20110513]

Comment 4

6 years ago
This is resolved? Or it's a wonfix?

Comment 5

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110627 Firefox/7.0a1

Just to clarify this. Was this fixed with a patch or was the resolution set to fixed just so as to close the issue?
(Reporter)

Comment 6

6 years ago
I am still seeing it in the nightly build on linux but do not in the regular build on linux so I would imagine its still in the nightly.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(In reply to comment #5)
> Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110627 Firefox/7.0a1
> 
> Just to clarify this. Was this fixed with a patch or was the resolution set
> to fixed just so as to close the issue?

See the status whiteboard. Bug 654809 made it so that the secondary color is based on the default text color. Since the default text color is determined by the theme, the secondary color implicitly follows the theme as well.

> I am still seeing it in the nightly build on linux

Seeing what, exactly?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 8

6 years ago
(In reply to comment #7)
> See the status whiteboard. Bug 654809 made it so that the secondary color is
> based on the default text color.

You probably mean bug 654411, not this bug 654809 (which is this bug).

Comment 9

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110729 Firefox/8.0a1
Mozilla/5.0 (Windows NT 5.1; rv:7.0a2) Gecko/20110727 Firefox/7.0a2

Verified issue with the latest mozilla central and Aurora using Win XP - the entire url text is showing the same color. 

Verified on Linux as well - no problems there.

Setting resolution to VERIFIED FIXED.
Status: RESOLVED → VERIFIED

Updated

5 years ago
Whiteboard: [fixed by bug 654809][bugday-20110513] → [fixed by bug 654411][bugday-20110513]
You need to log in before you can comment on or make changes to this bug.