If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Save"/"Save all" button in attachment pane has no icon on Mac

RESOLVED FIXED in Thunderbird 5.0b1

Status

Thunderbird
Theme
--
minor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: squib, Assigned: squib)

Tracking

Trunk
Thunderbird 5.0b1
All
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
Created attachment 530143 [details] [diff] [review]
Speculative fix

The save/save all button on the attachment pane should have an icon, but on Mac, it doesn't. This is a problem, since a person may reasonably want to customize the toolbar to show only icons.

Attached is a speculative fix. I think the issue is just that we forgot to add the new icon to pinstripe's jar.mn.
Attachment #530143 - Flags: review?(bwinton)
Comment on attachment 530143 [details] [diff] [review]
Speculative fix

Review of attachment 530143 [details] [diff] [review]:

Seems to fix the problem, although it's not centered vertically…

http://dl.dropbox.com/u/2301433/Screenshots/SaveIcon.png

Still, it's a step up, so r=me with that fixed.  :)

Thanks,
Blake.
Attachment #530143 - Flags: review?(bwinton) → review+
(Assignee)

Comment 2

7 years ago
Could you check what the value of -moz-box-align is in the computed styles for the toolbarbutton on Mac? Since I can't test Mac stuff directly, I want to make sure that's the issue (it's supposed to be -moz-box-align: center).
I don't see any -moz-box-align.

I do see "vertical-align: baseline", but I think the problem might be that in messageHeader.css (line 281) the toolbar-button gets 2px of padding on the bottom.

.msgHeaderView-button[type="menu-button"] > .toolbarbutton-menubutton-button {
[snip…]
    padding-bottom: 2px !important;
[snip…]
}

And if I remove that rule, the image goes to where it's supposed to be, but the Reply button in the message header also drops down.  So, perhaps the way to go is to override that rule for just this button, and make it have "0px padding !important"?

Later,
Blake.
(Assignee)

Comment 4

7 years ago
Created attachment 530338 [details] [diff] [review]
Fix vertical alignment of icon (I hope)

Ok, I think this is right, based on comment 3.
Attachment #530143 - Attachment is obsolete: true
Attachment #530338 - Flags: review?(bwinton)
Comment on attachment 530338 [details] [diff] [review]
Fix vertical alignment of icon (I hope)

Review of attachment 530338 [details] [diff] [review]:

Looks good to me.  Thanks!
Attachment #530338 - Flags: review?(bwinton) → review+
(Assignee)

Comment 6

7 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/6f7ab0c3e629
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a4
You need to log in before you can comment on or make changes to this bug.