Update install-module.pl to take advantage of modern CPAN features

RESOLVED WONTFIX

Status

()

Bugzilla
Installation & Upgrading
--
enhancement
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: Max Kanat-Alexander, Unassigned)

Tracking

Details

(Whiteboard: Requires CPAN 1.96)

(Reporter)

Description

7 years ago
Modern CPAN.pm has nice features like automatic mirror selection. Also, I believe it requires Parse::CPAN::Meta instead of explicitly using YAML.pm. So we should generally update install-module for this new version that just came out in March.
(Reporter)

Updated

7 years ago
Assignee: installation → mkanat
Status: NEW → ASSIGNED
Target Milestone: --- → Bugzilla 4.2
(Reporter)

Updated

7 years ago
Assignee: mkanat → installation
Target Milestone: Bugzilla 4.2 → ---

Updated

6 years ago
Status: ASSIGNED → NEW

Comment 1

5 years ago
CPAN 1.96 also supports META.json.
Whiteboard: Requires CPAN 1.96

Comment 2

2 years ago
install-module.pl is gone.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.