Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 654904 - Link tap highlight does not disappear after panning ends
: Link tap highlight does not disappear after panning ends
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Matt Brubeck (:mbrubeck)
Depends on:
Blocks: 653009
  Show dependency treegraph
Reported: 2011-05-04 17:40 PDT by Matt Brubeck (:mbrubeck)
Modified: 2011-07-14 21:33 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---

patch (1.77 KB, patch)
2011-05-04 19:47 PDT, Matt Brubeck (:mbrubeck)
wjohnston2000: review+
Details | Diff | Splinter Review

Description Matt Brubeck (:mbrubeck) 2011-05-04 17:40:12 PDT
Steps to reproduce:
1. Open and zoom in.
2. Press on a link, and...
3. ...without lifting your finger, drag to pan the page.
4. Stop panning.

Expected results: Tap highlight disappears after a moment.
Actual results: Tap highlight remains, even after panning stops.

Similar but not a duplicate of bug 625832.  That bug is about the tap highlight not disappearing immediately at the *start* of panning.  However, until a few days ago, the tap highlight at least disappeared at the *end* of panning.  Now it doesn't even do that.  I suspect this more recent regression is related to touch events (bug 544614).
Comment 1 Matt Brubeck (:mbrubeck) 2011-05-04 19:47:38 PDT
Created attachment 530224 [details] [diff] [review]

This was a regression from my patch in bug 653009, which removed the PanBegin listener in ContentTouchHandler.

This patch adds a PanBegin listener.  But instead of cancelling the tap highlight *and* discarding pending messages (which broke MouseMove messaging, which is why it was removed before), now it will *just* cancel the tap highlight.
Comment 2 Wesley Johnston (:wesj) 2011-05-05 09:01:44 PDT
Comment on attachment 530224 [details] [diff] [review]

Review of attachment 530224 [details] [diff] [review]:

Comment 3 Matt Brubeck (:mbrubeck) 2011-05-05 09:55:14 PDT
Comment 4 Antonio Gomes (tonikitoo) 2011-05-05 13:27:32 PDT
does it work for scrollable divs/iframes?
Comment 5 Matt Brubeck (:mbrubeck) 2011-05-05 14:35:39 PDT
Backed out because something that landed with this caused a new orange (Win debug Moth tabview/browser_tabview_bug597248.js):

This can probably land again once we figure out the cause of the test failures.
Comment 6 Matt Brubeck (:mbrubeck) 2011-05-06 09:03:59 PDT
Followup re-landed:
Comment 7 Andreea Pod 2011-05-10 02:52:47 PDT
Verified fixed on build: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110508 Firefox/6.0a1 Fennec/6.0a1 
Device: LG Optimus 2X (Android 2.2)

Note You need to log in before you can comment on or make changes to this bug.