browser quits on startup after installing java

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: mb, Assigned: Joe Chou)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.18 i586; en-US; 0.7) Gecko/20010112
BuildID:    2001011421

Mozilla works fine after initial installation. After installing the java plugin
according to the procedures detailed on the Mozila WWW pages, Mozilla quits on
loading. This happens with version 0.7 and the "daily build" version identified
above.

Reproducible: Always
Steps to Reproduce:
1. Get the java plugin from
ftp.netscape.com:/pub/netscape6/english/6.0/unix/linux22/jre.xpi
and store it locally.
2. Open the directory where jre.xpi is in mozilla, then double click on jre.xpi.
Confirm that the plugin is "trusted" and should be installed.
3. Notice that mozilla indicates that the installation is taking place, with
various files being copied. Then the installation dialog disappears.
4. Quit mozilla, then load it again in the usual way.

Actual Results:  Mozilla displays some text and then quits, before opening any
windows.

Expected Results:  Mozilla loads as usual and opens a browser window, without
quitting.

The messages displayed by mozilla leading up to the point where it quits:

Registering plugin 15 for:
"application/x-java-bean;version=1.1.3","Java(tm) Plug-in",""
Registering plugin 16 for: "application/x-java-bean;version=1.2","Java(tm)
Plug-in",""
Registering plugin 17 for:
"application/x-java-bean;version=1.2.1","Java(tm) Plug-in",""
Registering plugin 18 for:
"application/x-java-bean;version=1.2.2","Java(tm) Plug-in",""
Registering plugin 19 for: "application/x-java-bean;version=1.3","Java(tm)
Plug-in",""
Registering plugin 20 for:
"application/x-java-bean;jpi-version=1.3.0_01","Java(tm) Plug-in",""
# # An unexpected exception has been detected in native code outside the
VM.# Program counter=0x40993a1d
#
# Problematic Thread: prio=1 tid=0x8053e18 nid=0x25d0 runnable
#
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Resource temporarily unavailable
(Reporter)

Comment 1

17 years ago
In case it matters: this is linux version 2.2.18, based on a redhat 5.2
installation but it has been updated somewhat.

Comment 2

17 years ago
Uh Uh, excellent report mb@gem.win.co.nz.
Sending to OJI, they probably know what this garbage means.
Note : first time I see this error reported...
Assignee: asa → edburns
Component: Browser-General → OJI
QA Contact: doronr → shrir

Comment 3

17 years ago
what ver of glibc are you using? can you give us an ls of your nc4 and moz 
plugins directory? what is your patch? I presume you're running xfree 3.3.6?

also, can you give us a santized environment variable list? (mostly looking for 
libpaths, javapaths ..)
(Reporter)

Comment 4

17 years ago
Using glibc version 2.1.92 supplied by redhat. I also still have the glibc 2.0.7
libraries installed, since it appears that certain programs rely on their
presence. /usr/lib/libc.so.6 is a symbolic link to libc-2.1.92, and is the file
that mozilla appears to link with, so I presume it is using version 2.1.92. But
I am not very clever with these things, so maybe I am making a mistake.

$ ls -l /usr/lib/mozilla/plugins
drwxr-xr-x   6 root     root         1024 Jan 15 22:09 java2
lrwxrwxrwx   1 root     root           44 Jan 16 10:54 libjavaplugin_oji.so ->
java2/plugin/i386/ns600/libjavaplugin_oji.so
-rwxr-xr-x   1 root     root        13376 Jan 13 07:59 libnullplugin.so

Sorry, I am not sure what you mean about nc4 plugin directory...

I seem to be using XFree86 3.3.5
I don't seem to have a LIBPATH or JAVAPATH environment variable. Could this be
the problem? I tried running mozilla using run_mozilla, and it looks like it set
up the following variables (still didn't work though):MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
. being /usr/lib/mozilla , which is where the rpm installation put it.
As I have mentioned I am not very familiar with this stuff, so I may be missing
something obvious. I just hope I am not wasting anyone's time with something
inconsequential. However, if there is anything that I can do to help clarify
issues surrounding the problem, I will be happy to try it. Thanks.
Component: OJI → Browser-General
QA Contact: shrir → doronr

Comment 5

17 years ago
Joe, can you please investigate this?
Assignee: edburns → joe.chou
(Assignee)

Comment 6

17 years ago
I've tried Mozilla0.7 with Java plugin, and it worked fine.
Here are some questions:
1) You attached the following to show where the Java plugin lib was on your
system:
$ ls -l /usr/lib/mozilla/plugins
drwxr-xr-x   6 root     root         1024 Jan 15 22:09 java2
lrwxrwxrwx   1 root     root           44 Jan 16 10:54 libjavaplugin_oji.so ->
java2/plugin/i386/ns600/libjavaplugin_oji.so
-rwxr-xr-x   1 root     root        13376 Jan 13 07:59 libnullplugin.so

Should the directory be ".../mozilla/dist/bin/plugins"?
2) If you remove libjavaplugin_oji.so in the dir above, start mozilla again, go
to a site with some applets (try java.sun.com), you'll be prompted to load Java
plugin, just following the instructions. When done, exit mozilla, and restart
mozilla again. Do you still have the same problem?
3) Could you run Netscape6 on your machine?
(Reporter)

Comment 7

17 years ago
To answer your questions:
1. The directory I mentioned is where the RPM installed Mozilla.
2. The process you describe is what I used to install the Java plugin in the
first place.
3. I haven't tried Netscape 6 although Netscape 4 works ok.
However, having enabled the Java plugin again, it now appears to work
fine in Mozilla and I can access several WWW pages that have Java without
any problems. So we can say that in my case the problem is fixed.
As far as I am aware, the only thing of consequence that has changed since
the problem occured is the installation of XFree86 version 4.0.2, replacing
version 3.3.5. I don't know whether it is necessary to look into the problem
further; if there is anything I can do I would be happy to help. But in my
particular case, all is well now.
(Assignee)

Comment 8

17 years ago
Thanks for the replied information. Since the original problem is not a problem
anymore, I'll mark it as WORKSFORME now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.