Site Tab Modal Notification Steals Focus

RESOLVED WORKSFORME

Status

()

Toolkit
Notifications and Alerts
--
minor
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Fritz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110504 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110504 Firefox/6.0a1

Going to the Free library login site and opening a new tab steals focus.



Reproducible: Always

Steps to Reproduce:
1.  Visit http://libwww.freelibrary.org/account/login.cfm
2.  Click on on the Library Card Number form
3.  Ctrl+T opens new tab

Actual Results:  
A new tab is opened but focus remains on the Free Library page instead of the new tab.

Expected Results:  
Focus should be on new tab.

Also, clicking on any link on the page opens the prompt but that may be intended behavior although I would imagine the page of the link clicked should open.
This is WFM using that Build.

Is your Issue reproducible without Extensions in Safe-Mode and/or using a new Profile?
https://support.mozilla.com/en-US/kb/Safe+Mode
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile
Version: unspecified → Trunk
Component: Tabbed Browser → Notifications and Alerts
Product: Firefox → Toolkit
Version: Trunk → unspecified
Resolving as per comment 1. I can't reproduce this either.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.