Quitting firefox when multiple windows are open loses any open tabs

VERIFIED INCOMPLETE

Status

()

Firefox
Session Restore
--
critical
VERIFIED INCOMPLETE
7 years ago
7 years ago

People

(Reporter: ed, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-05-18])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When you set firefox to reopen windows and tabs from last time it does not work if you have multiple windows open.




Reproducible: Always

Steps to Reproduce:
1.start firefox and browse to a site, do view source on that site so that 2 windows are open, (have reopen windows and tabs from last time set in preferences)
2. quit firefox
3. restart firefox, it shows a single window with the default start page

Actual Results:  
I did not get my last open tab from the previous session (nor the view source window)

Expected Results:  
I expect the open tabs from the previous session or firefox to advise me to shut all but one window before quitting.

In the actual case I had two windows each with a set of tabs in them and also a view source window. It looks like the last closed window is restored and that this is the view source window. 

This is IMHO the least useful thing to do, either restore all open tabs or close windows in a correct sequence or refuse to quit and get the user to decide which single window should be restored.

I did lose a lot of work hence the critical rating.

Updated

7 years ago
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore

Comment 1

7 years ago
Works for me on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110505 Firefox/6.0a1

After restarting Firefox all the tabs are reopened except Page Source "window" wich is called a pannel, so it does'n behave as a regular window.
How did you close Firefox in step 2? Have you closed each individual window? Please elaborate a bit more. Thanks.
Whiteboard: [closeme 2011-05-18]
(Reporter)

Comment 3

7 years ago
I will go back and do this again carefully recording every step and provide supporting detail.

The actual event was a system reboot when FF had two tabbed windows and a source "panel" open. On rebooting I had lost all tabs, I tried to provide a simpler scenario to report and clearly botched that.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 4

7 years ago
Reporter, do you have anything new to add about this issue?
No reply, INCOMPLETE. Please retest with Firefox 4 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest Firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.