Last Comment Bug 654967 - Firebug stays disabled when switching back from Beta to Aurora
: Firebug stays disabled when switching back from Beta to Aurora
Status: VERIFIED FIXED
[channel-switcher]
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: 5 Branch
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://getfirebug.com/releases/firebu...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-05 03:46 PDT by Simon Proctor
Modified: 2011-05-12 07:14 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
extensions.sqlite (384.00 KB, application/x-sqlite3)
2011-05-05 07:24 PDT, Henrik Skupin (:whimboo)
no flags Details

Description Simon Proctor 2011-05-05 03:46:02 PDT
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:5.0a2) Gecko/20110504 Firefox/5.0a2
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:5.0a2) Gecko/20110504 Firefox/5.0a2

I'm not sure if I've categorised this correctly. I saw the post this morning about testing the Channel Switcher. I'm currently running on the Aurora channel and so tested switching to Beta and back to Aurora. The switch back and forth was fine, but there was an issue with Firebug. 

In Aurora I was using Firebug 1.8.0a2 from the getfirebug site. When I switched to Beta it was disabled as being incompatible. When I switched back to Aurora it was still disabled. I tried to check for updates with no luck. Reinstalling the addon from the getfirebug site fixed the issue. 

I'm going to try again and see if it happens every time and will update the bug once I have. 

Reproducible: Didn't try

Steps to Reproduce:
1. Run Firefox Aurora with an addon for it installed (Firebug as an example)
2. Use Channel Switcher to Switch to Beta
3. Use Channel Switcher to Switch back to Aurora


Actual Results:  
Addon now disabled and needs to be reinstalled

Expected Results:  
Addon sould have re-enabled on switching back.
Comment 1 Simon Proctor 2011-05-05 03:51:51 PDT
I ran through the process again and the same thing happened. When the Aurora version ran it didn't seem to check Firebug to see if there was an update and it's disabled. Manaully checking for updates doesn't help either. Going to reinstall which fixed the issue last time.
Comment 2 Henrik Skupin (:whimboo) 2011-05-05 07:23:25 PDT
Same on OS X. Looks like that we do not trigger a compatibility update check when "downgrading" from a bX to an a2 build.

Dave, I would say we have to try to fix that for Firefox 5.
Comment 3 Henrik Skupin (:whimboo) 2011-05-05 07:24:27 PDT
Created attachment 530307 [details]
extensions.sqlite

The extension registry after switching back from Beta to Aurora.
Comment 4 Dave Townsend [:mossop] 2011-05-05 09:52:47 PDT
This is behaving as expected since Firebug has bad information in its update.rdf. The add-ons install.rdf claims compatibility with up to 5.0.* but the update.rdf says it only works up to 4.0. When we switch versions we override compatibility with whatever the update.rdf says. You'll see that you can install Firebug in beta and then switch to aurora and you do get the compatibility check.

The case where you don't get it is when firebug is already disabled in beta, to avoid showing the dialog unnecessarily we only show the compatibility UI when an add-on was previously enabled and has become disabled by the application change.
Comment 5 Henrik Skupin (:whimboo) 2011-05-06 10:49:48 PDT
CC'ing Rob and John so we can get this fixed in the update.rdf of Firebug. Dave, moving over to extension compat?
Comment 6 John J. Barton 2011-05-06 12:51:23 PDT
Thanks Henrik. I no longer work on Firefox and Rob no longer works on Firebug. Please copy Jan "Honza" Odvarko on Firebug issues
Comment 7 Jan Honza Odvarko [:Honza] 2011-05-10 06:53:28 PDT
I have fixed the update.rdf file for Firebug 1.8
http://getfirebug.com/releases/firebug/1.8/update.rdf

The max version is set to 5.0.*

Please verify and let me know if it still doesn't work.

Thanks!
Honza
Comment 8 Henrik Skupin (:whimboo) 2011-05-12 04:06:15 PDT
Thanks Jan. It works now as expected. Looks like we can move this bug over to extension compatibility. Marking as verified fixed.
Comment 9 Jan Honza Odvarko [:Honza] 2011-05-12 07:14:03 PDT
Great, thanks for the update!
Honza

Note You need to log in before you can comment on or make changes to this bug.