Closed Bug 654969 Opened 9 years ago Closed 9 years ago

Text in comments wraps badly when setting a larger Monospace font size in Firefox options, started with BMO upgrade

Categories

(bugzilla.mozilla.org :: General, defect)

Production
x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: steffen.wilberg, Assigned: dkl)

References

Details

Attachments

(2 files)

After the BMO upgrade, the text in the comments boxes wraps badly when the Monospace font size (in Firefox Options - Contents - Fonts - Advanced) is set to a larger value, like this:

A full line
one or two words
a full line
one or two words

Font size 14 works, size 15 or larger breaks the site (on Windows 7 running Nightly).
i'm not really sure what the problem is you're trying to report; it works fine for me even with massive values for the font size.

can you please attach a screenshot of the behavour you're seeing.
do you mean it looks like attachment 408700 [details] (from bug 524795) ?
this is fixed in 4.2 by bug 551468.  i'll investigate the viability of backporting that fix to bmo.
Keywords: regression
Attached image screenshot β€”
It's similar to attachment 408700 [details] indeed.
Note that the additional comments box is quite a bit wider than the previous comments, which might be part of the problem.

Backporting would be nice, as I can't reproduce this on https://landfill.bugzilla.org/bugzilla-tip/show_bug.cgi?id=14940.
Patch to back port 4.2 comment wrapping to bmo. Patch from 4.2 actually applies cleanly, passes all sanity checks, and seems to fix the issue for me on my local instance.

Please review
dkl
Assignee: nobody → dkl
Status: NEW → ASSIGNED
Attachment #530322 - Flags: review?(glob)
Comment on attachment 530322 [details] [diff] [review]
Patch to back port 4.2 comment wrapping to bmo (v1)

r=glob
Attachment #530322 - Flags: review?(glob) → review+
OS: Windows 7 → All
Depends on: 654921
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Works fine, thanks for the quick turnaround!
Status: RESOLVED → VERIFIED
yay!  and I'd like to point out it's not just if you change font size in firefox. I increase the default font DPI on all my windows machines to 120 or 125, which had the same ugly effect on wrapping.
You need to log in before you can comment on or make changes to this bug.