Closed Bug 654980 Opened 10 years ago Closed 10 years ago

Firefox unloading/exiting while tabs are still loading results in loss of session data

Categories

(Firefox for Android Graveyard :: General, defect)

Other
Other
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 630398

People

(Reporter: CoJaBo-Bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 4.0.1

Firefox unloading/exiting while tabs are still loading results in loss of session data.

Reproducible: Always

Steps to Reproduce:
1. Load one or more tabs that take some time to load (also applies when restoring session from about:home page)
2. Switch away and either load a memory-intensive app or reboot the phone or otherwise cause Firefox to exit/unload.
3. Re-load Firefox within one hour so session is automatically restored.

Actual Results:  
Only the tabs that had completed loading at time of exit are saved. The rest load blank pages with no history.

Expected Results:  
All tabs are present, with history intact.

Tested on Droid X
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630398
This sounds more like an OOM issue with the device from the steps provided.
The issue as described in this bug (incompletely loaded tabs not saved) no longer occurs. Other issues presumably related to Bug 630398 (outdated session being restored) still seem to persist as noted in my comment on that bug.
You need to log in before you can comment on or make changes to this bug.