Last Comment Bug 655011 - Remove WinCE code from libpref
: Remove WinCE code from libpref
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Preferences: Backend (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla7
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-05 07:26 PDT by Ed Morley [:emorley]
Modified: 2011-06-08 14:59 PDT (History)
5 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from libpref (5.83 KB, patch)
2011-05-05 08:17 PDT, Ed Morley [:emorley]
benjamin: review+
Details | Diff | Splinter Review
Remove WinCE code from libpref (5.84 KB, patch)
2011-06-07 09:06 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-05-05 07:26:04 PDT
WinCE & Windows Mobile code is being removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the modules/libpref/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/modules/libpref/
Comment 1 Ed Morley [:emorley] 2011-05-05 08:17:56 PDT
Created attachment 530318 [details] [diff] [review]
Remove WinCE code from libpref
Comment 2 Ed Morley [:emorley] 2011-05-05 15:13:04 PDT
http://dev.philringnalda.com/tbpl/?tree=Try&rev=c49489125caa
Comment 3 Ed Morley [:emorley] 2011-05-16 00:48:10 PDT
Dan, ping for review please :-)
Thanks!
Comment 4 Ed Morley [:emorley] 2011-05-23 12:47:48 PDT
Comment on attachment 530318 [details] [diff] [review]
Remove WinCE code from libpref

Removes ~7 small blocks of WinCE ifdefs; has passed try.
Thanks :-)
Comment 5 dwitte@gmail.com 2011-05-23 12:55:59 PDT
Would be better for bsmedberg to review this, I think... he's more up to date on the status of WINCE than I am!
Comment 6 Ed Morley [:emorley] 2011-05-23 12:59:29 PDT
Comment on attachment 530318 [details] [diff] [review]
Remove WinCE code from libpref

Thanks :-)
Comment 7 Ed Morley [:emorley] 2011-06-06 01:21:39 PDT
bsmedberg, ping for review please :-)
Comment 8 Ed Morley [:emorley] 2011-06-06 01:22:11 PDT
bsmedberg, ping for review please :-)
Comment 9 Ed Morley [:emorley] 2011-06-07 09:06:27 PDT
Created attachment 537803 [details] [diff] [review]
Remove WinCE code from libpref

Updated to tip; carrying forwards r+.
Comment 10 Daniel Holbert [:dholbert] 2011-06-07 10:52:26 PDT
http://hg.mozilla.org/projects/cedar/rev/4f650a5e0488

Note You need to log in before you can comment on or make changes to this bug.