Closed Bug 655202 Opened 10 years ago Closed 10 years ago

Message header alignment is off (from / subject / to)

Categories

(Thunderbird :: Message Reader UI, defect)

x86
All
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 8.0

People

(Reporter: work, Assigned: Paenglab)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Thunderbird/3.1.10

Since From and To fields have emails (styled with padding so the :hover effect looks decent), the subject field ends up aligned a few pixels to the right.

Also, the From field value is aligned one pixel too high.

Reproducible: Always

Steps to Reproduce:
1. View message


Actual Results:  
Headers are mis-aligned


(Really annoying that cosmetic problems are marked "trivial".)
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
I checked it under Windows and Linux. It's the same, so Platform -> All
OS: Mac OS X → All
This patch reduces the padding of the bubble when the address is hovered. This is also half a ui review about this narrower hover appearance.

I tried also a negative margin-left, but this ended in a bubble which is cut on the left on the from: row.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #530692 - Flags: review?(nisses.mail)
The bug I filed didn't have to do with the padding of the address bubbles -- I'm not sure why that would be the answer to the alignment problem. I think they look fine, and though I can't see the results of your changes, I'd be concerned that less than 3px left/right padding would be too small in this use case.

You can't just put a 1px left margin on the subject and leave it at that?
It's not only the subject, all other headers in Headers/All view are correct aligned. Only the from:, to: and newsgroups: header are misaligned.

I'm awaiting the review. I can also increase the gap between the header titles and the labels except for the tree mentioned. But as wrote this increases the gap and is this desired?
"all other headers in Headers/All view are correct aligned"; this does not seem to be the case on OSX. All the additional headers seem to have *zero* padding between the label and the value; the To/Subject/From display is approximately correct, just not aligned. (I'll attach a screenshot.)

If Subject had one more pixel, it would be aligned with To/From; it would be great if all the other headers could then be formatted with the same spacing.
Then this is a special case of OSX. Under Win or Linux all headers are with this patch correct aligned.

I propose first to solve the from: subject: and to: headers. Then with a followup Bug someone with a Mac can solve the expanded headers aligning.
(In reply to comment #9)
> Then this is a special case of OSX. Under Win or Linux all headers are with
> this patch correct aligned.
> 
> I propose first to solve the from: subject: and to: headers. Then with a
> followup Bug someone with a Mac can solve the expanded headers aligning.

Agreed, lets file a new bug about that.
Comment on attachment 530692 [details] [diff] [review]
Patch reducing the address bubble padding

Looks good. r+ me.
Attachment #530692 - Flags: review?(nisses.mail) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/f516d5606ecd
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
You need to log in before you can comment on or make changes to this bug.