Closed Bug 655203 Opened 9 years ago Closed 9 years ago

First partner repack builder fails to upload status file if platform not used by any partner repack

Categories

(Release Engineering :: Release Requests, defect, P2)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rail, Assigned: rail)

References

Details

Attachments

(1 file)

Caught this in preproduction when linux64 partner repack finished before all other platforms. Since none of the repacks use linux64 there was nothing to rsync to stage and partner-repacks directory wasn't created.

touch: cannot touch `/pub/mozilla.org/firefox/nightly/4.0.2-candidates/build1//unsigned/partner-repacks/partner_build_linux64': No such file or directory

I believe this prevents (auto)signing to finish its process since it waits for these status files.

Will test the patch in staging.
Attachment #530544 - Flags: review?(coop)
Looks fine:

bash -c 'ssh -oIdentityFile=~/.ssh/ffxbld_dsa ffxbld@preproduction-stage.build.mozilla.org mkdir -p /pub/mozilla.org/firefox/nightly/4.0.2-candidates/build1//unsigned/partner-repacks/'
.....
program finished with exit code 0
elapsedTime=0.334700
Attachment #530544 - Flags: review?(coop) → review+
Comment on attachment 530544 [details] [diff] [review]
Explicitly create partner-repacks directory before touch

Checked in: http://hg.mozilla.org/build/buildbotcustom/rev/cc294971313c
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Component: Release Engineering: Custom Builds → Release Engineering: Releases
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.