user getting major update prompt on Linux, when required c++ version not supported on his system

NEW
Unassigned

Status

()

Firefox
General
7 years ago
7 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
"I'm using 3.6.17 on an old RHEL5 with GLIBCXX_3.4.8. I was prompted to upgrade to 4.0.1 which needs GLIBCXX_3.4.9" - @bluesmoon on twitter.

not sure if this is his distro or us.

Comment 1

7 years ago
@bluesmoon here.  This is what's been happening.

A long time ago, when firefox 4beta was pushed out with tab group & sync support, I downloaded it on my RHEL5 desktop and MBP laptop.  I guess this put me into the beta program.

Each time there was a new beta out, I was prompted to upgrade, and I did so.  No problem on MacOSX, but on RHEL, one day it stopped working with the GLIBCXX error that I described to Dietrich.  Now I should add that this is RHEL5.5, but the packages on it can only be upgraded to what we have on our own local mirror, so while a newer gcc/g++ might be available for RHEL5.5, I can't install it (easily).  I've tried for months to get all the package dependencies sorted out to get this working, but to no avail.

In the mean time, I reverted to firefox 3.6, which still worked.  I should also mention that I have these browsers installed in different directories, and each of them uses a different profile directory (I have 3.0, 3.5, 3.6 and 4.0).  I need to install plugins and extensions separately for each of them.

Today, while using firefox 3.6, I was prompted to download firefox 4.0.1.

So here's what I think.

1. I'm not sure why I was prompted for 4.0.1 while using 3.6.  I'd have guessed that only 4.0 users would get this prompt.
2. In any event, before presenting the user with a choice to upgrade, it should be trivial to check if their OS supports whatever the upgrade will need.  For most people, after they've done the upgrade, if it fails, they're screwed, because they've now lost their only means of downloading an upgrade.  Most people don't have multiple versions of the browser that they can fall back on, so they'll be forced to use Safari or (the horror) IE.  (assuming of course that they haven't also downloaded Chrome and Opera, but then they're probably like me and will just bitch on twitter hoping that @codepo8 is awake at the time and leave it at that :D)
3. You may not need to fix my particular problem, since it has more to do with the RHEL5 mirrors that I'm allowed to use than anything you can control (although it would be nice if we didn't change ABI dependencies (I hope to Bob it's an ABI thing or I'm just a fool) with just an increase in patchlevel).
You need to log in before you can comment on or make changes to this bug.