[DOGFOOD] crash closing view source page

RESOLVED DUPLICATE of bug 576933

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 576933
7 years ago
7 years ago

People

(Reporter: Louis-Rémi BABE, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
The problem occurs constantly.

Crash report here: https://crash-stats.mozilla.com/report/index/fc9598bb-64de-431a-848f-1fcd32110506

I'm surprised to see many "possible duplicates" that have been fixed years ago.
> The problem occurs constantly.

The stack you link to is showing a crash inside your Linux system libraries due to an X11Error (libbonoboui, etc).

The "possible duplicates" are just any crashes with the same top frame, which means anything crashing due to an X11Error.

What exact versions of XOrg and libbonoboui are you using?  Anything else interesting about your setup X or GTK wise?
Component: XML → Widget: Gtk
QA Contact: xml → gtk
(Reporter)

Comment 2

7 years ago
Sorry Boris, I should have been more specific: "The problem occurs constantly on my machine", I'm pretty sure it's not the case for everyone else out there.

I should have also linked the possible duplicates I was referring to: #17584 (reported for Windows) and #63235

The versions reported by my packet manager are:
xorg: 1:7.6+4ubuntu3
libbonoboui2-0: 2.24.5-0ubuntu1

I never tweak my X or GTK setup manually.

Let me know if I can provide any other helpful info.

Regards,

Louis-Rémi
Karl, any ideas?
(Reporter)

Comment 4

7 years ago
After some test, additional info: the bug only appears when I use Ubuntu with Unity and when Firebug is enabled at the same time.
If I switch back to Ubuntu Classic and leave Firebug enabled, the problem disappear. If I disable Firebug and keep using Unity, the problem disappear.
I was using Firebug 1.7.1b2, then upgraded to 1.8.0a2 and downgraded to 1.7.0, but it didn't help.
I wouldn't have thought that a shutdown crash would prevent a dog from eating its food, but this should be fixed in 4.0.1.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 2.0 Branch
Duplicate of bug: 576933
You need to log in before you can comment on or make changes to this bug.