plugincheck reports missing flash as firefox disabled.

RESOLVED WONTFIX

Status

Websites
plugins.mozilla.org
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: rillian, Unassigned)

Tracking

Details

(URL)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:5.0a2) Gecko/20110425 Firefox/5.0a2
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:5.0a2) Gecko/20110425 Firefox/5.0a2

I visited http://www.mozilla.com/plugincheck/ today, and it displayed a red box saying,

'''
Missing FLASH?

For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version.
'''

This is incorrect; this Firefox instance has never had flash. If you're going to use this wording, it would be better to track whether firefox had blocked the plugin, instead of assuming that's the only reason it would be missing.

Reproducible: Always

Steps to Reproduce:
1. Make sure flash is not installed
2. Visit http://www.mozilla.com/plugincheck/
3.

Actual Results:  
"For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version."

Expected Results:  
Personally, I'd rather it didn't advertise flash, but a simpler,

"Want Flash? It's not currently installed. Get the latest version here." would be more acceptable.

Comment 1

7 years ago
This was added as a contingency for disabling flash via a blocklist, and is only displayed when you visit the page without a referrer and with flash not detected. The intent was to alert people to the fact that flash isn't installed. "Missing Flash?" is a question, and our assumption if the answer is "no" would be that you'd carry on as normal. It's by design, and more info and rationale is available on bug 633285.

I think the wording as it is is fine, because if you know you're not missing Flash, you're not going to upgrade it.

Comment 2

7 years ago
...err... you're not going to install it. the wording of the text that follows the question might be tweaked a little, and I'll talk to some folks about it.
(Reporter)

Comment 3

7 years ago
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Updated

7 years ago
Duplicate of this bug: 684008

Updated

7 years ago
Duplicate of this bug: 695302

Updated

7 years ago
Duplicate of this bug: 695302

Comment 7

7 years ago
Changing this to reopened since the wording hasn't been changed and bug 695302 was marked as a duplicate.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---

Comment 8

7 years ago
wording suggestions welcome.

Comment 9

7 years ago
Bug 695349 created to address text changes.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.