Can't trigger Firefox 5 compatibility test (placeholder) in validator

RESOLVED FIXED in 6.0.10

Status

addons.mozilla.org Graveyard
Developer Pages
P1
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: kumar, Assigned: basta)

Tracking

unspecified
6.0.10

Details

Attachments

(1 attachment)

Created attachment 530657 [details]
xpi that supports Firefox 5

In bug 650391 there was a no-op test for Firefox 5 added but I can't get this to run.  What am I doing wrong?

STR:
1. edit validator/validate.py to pass this in: for_appversions = {'{ec8030f7-c20a-464f-9b0e-13a3a9e97384}': ["5.0.*"]}
2. run python addon-validator -o json ~/path/to/desktop-and-mobile-6.xpi (attached)

This is supposed to output a notice, right?  This is all I get:

{
    "errors": 0,
    "detected_type": "extension",
    "success": true,
    "warnings": 0,
    "notices": 0,
    "message_tree": {},
    "ending_tier": 5,
    "messages": [],
    "metadata": {
        "version": "3.0",
        "id": "DesktopMobile6Kumar@smartware.com",
        "name": "Desktop And Mobile 6"
    }
}
Assignee: nobody → mbasta
Blocks: 649863
I will investigate this further...
Assignee: mbasta → kumar.mcmillan
Target Milestone: --- → 6.0.10
Priority: -- → P1
(Assignee)

Comment 2

7 years ago
Can you try with 5.0a2 instead of 5.0.*? 5.0.* isn't on the Firefox appversions page yet.
(In reply to comment #2)
> Can you try with 5.0a2 instead of 5.0.*? 5.0.* isn't on the Firefox
> appversions page yet.

I get the same exact output with 5.0a2
(Assignee)

Comment 4

7 years ago
Just looked into it, there was indeed a weird bug that wasn't being caught by the unit tests. I'll be pushing the fix a little later tonight with the stuff for bug 654300.
Assignee: kumar.mcmillan → mbasta
(Assignee)

Comment 5

7 years ago
This contains the fix and the updates to the test:

https://github.com/mattbasta/amo-validator/pull/16
(Assignee)

Comment 7

7 years ago
Merged:

https://github.com/mozilla/amo-validator/commit/052768860cb6026792b47ba7087f2a46aedfb3f1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.