fallback to global default chrome if user choice not found

VERIFIED DUPLICATE of bug 53670

Status

Core Graveyard
Skinability
VERIFIED DUPLICATE of bug 53670
17 years ago
9 years ago

People

(Reporter: dveditz, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From the newsgroups: User has two Mozilla installations (one is actually 
ActiveState's Komodo), has downloaded a global skin from x.themes.org into one 
of them, and selected that theme in his profile. When he switches to the other 
Mozilla (without the chosen theme) it will not start at all.

If we can't find the skin referenced in the profile "user-skin.rdf" we should 
fallback to the global "user-skin.rdf" for the default which must exist unless 
the installation has been mucked with.

Ditto for locales.

Comment 1

17 years ago
isn't this in effect a dup of bug 53670:

New build won't start if 3rd party theme is used in old build [@
nsCSSFrameConstructor::ConstructDocElementFrame]

Comment 2

17 years ago
It's a dup, but I'd like to keep this bug open. Hyatt/Ben say this would never
work in  bug 53670, but we can do a last attempt ;)

Comment 3

17 years ago
The other bug is reopened marking this as a duplicate of it.

*** This bug has been marked as a duplicate of 53670 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified dupe of reopened bug 53670: "New build won't start if 3rd party theme
is used in old build [@ nsCSSFrameConstructor::ConstructDocElementFrame]"
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.