an event handler attached to resize on window object causes UI to freeze

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
7 years ago
4 years ago

People

(Reporter: Wojciech Ryrych, Unassigned, NeedInfo)

Tracking

4.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

I attached an event hander to the resize event on window object using jQuery. When window of a browser resizes, an image displayed in the lightbox is re-scaled. 
It is extremely slow in Firefox4/Kubntu 10.10. UI freezes for a while and it uses much CPU. Sometimes even whole UI disappears and the window is empty – plain window.

It was tested in:
• Chromium (Linux)
• Opera (Linux)
• Firefox 3.6.x (Win7)
• IE8 (Win7)
and it works

I also asked people to test it in the #Kubuntu channel, one man answered and told me that his Firefox crashed.

Reproducible: Always

Steps to Reproduce:
1. click on the thumbnail
2. wait till the image loads – it is quite large – 4.5MB
3. when it loads, resize the window a few times

Actual Results:  
UI freezes and sometimes Firefox crashes

Expected Results:  
smooth process of resizing
(Reporter)

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 1

7 years ago
Verified as crashing on Windows 7 with aero on Firefox 4.0.1 and 6.0a1 (Nightly)

What happens on Windows 7 is that Firefox goes into a lock where the UI disappears and paints the document area black. It causes the mouse to be frozen to the crashed window, which is unresponsive and you must use ctrl+alt+del to kill the process.

To produce this, step 3 was to only resize the window smaller and an almost instant crashed occured.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626963
(Reporter)

Comment 3

7 years ago
Justin: it is not exactly the same. So in this case we have two bugs not one. In my widget the modal window appears only if size of the window is smaller than 300px (size of the minimal size of the lightbox).

What I meant by freezing is that when I resize the window and there is no modal – I am resizing it but it is still bigger than 300px, Firefox’s UI freezes, CPU usage is high.

Actually I have not got any crash on my Kubuntu. I wrote about this because some people experienced it.

I would like to know if frezes are caused by Firefox, Kubuntu, or X.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

7 years ago
OK, I’ve updated the script to reflect the situation. I removed modal windows. So what I am reporting is that Firefox chugs while resizing its window.
On my Kubuntu UI freezes for a moment while doing it.
(Reporter)

Updated

7 years ago
Summary: an event handler attached to resize on window object causes UI to freeze or crash → an event handler attached to resize on window object causes UI to freeze

Comment 5

6 years ago
Verified as crashing on Windows 7 64 bit ultimate with aero on Firefox 11.0a1 (2011-12-03) (Nightly)

Firefox goes into a lock where the UI disappears and paints the document area black. have to use alt+F4 to quit,

Code used in html was :

$(window).bind('resize', function () { 
    alert('resize');
});

But crash does Not occur when the below is used

$(window).resize(function () {    
    alert('resize');
});

Reproducability :100%; 

PS: code works fine in IE 9 and Chrome (15.0.874.121 m)

Comment 6

6 years ago
(In reply to justshams from comment #5)
> Verified as crashing on Windows 7 64 bit ultimate with aero on Firefox
> 11.0a1 (2011-12-03) (Nightly)
> 
> Firefox goes into a lock where the UI disappears and paints the document
> area black. have to use alt+F4 to quit,
> 
> Code used in html was :
> 
> $(window).bind('resize', function () { 
>     alert('resize');
> });
> 
> But crash does Not occur when the below is used
> 
> $(window).resize(function () {    
>     alert('resize');
> });
> 
> Reproducability :100%; 
> 
> PS: code works fine in IE 9 and Chrome (15.0.874.121 m)

sorry: crash happens even on the second code snippet!

Comment 7

4 years ago
Is this still an issue with current Firefox builds? If so, please attach the testcase you are using or give the link to the web page (the URL in this report is no longer valid).
Flags: needinfo?(rrh)
OS: Linux → All
Hardware: x86 → All

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.