Crash upon loading attached page.

VERIFIED FIXED in mozilla1.0

Status

()

--
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: vectro, Assigned: pavlov)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16 i686; en-US; 0.7) Gecko/20010105
BuildID:    2001010517

Mozilla crashes after printing on the console "Document file:///tmp/index.html
loaded successfully". Sometimes it dosen't happen on the first try. Sometimes it
hangs instead.

Yes, I know it's not valid HTML. It still shouldn't crash.

Reproducible: Sometimes

My apologies if this was placed in the wrong category. It's in 'quirks' mode and
dosen't crash if I remove the javascript, so I thought this was a good place to
start.
(Reporter)

Comment 1

18 years ago
Created attachment 22627 [details]
HTML that makes mozilla crash.
(Reporter)

Updated

18 years ago

Comment 2

18 years ago
WORKSFORME
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001011508

Reporter: Try using one of the latest nightlies and see if that fixes the problem.
(Reporter)

Comment 3

18 years ago
Loaded once fine. Hit reload, crashed.

Ironically, it's the same system:
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001011508
Looks like the crahs happens in imagelib code, I see the crash on Win2k,
confirming and reassigning.
Assignee: jst → pnunn
Status: UNCONFIRMED → NEW
Component: DOM Level 0 → ImageLib
Ever confirmed: true
OS: Linux → All
QA Contact: desale → tpreston
Hardware: PC → All

Comment 5

18 years ago
This just looks like another version of the
1x1 stealth tracker image. 
probably a duplicate.
Status: NEW → ASSIGNED

Updated

18 years ago
Target Milestone: --- → mozilla1.0

Comment 6

18 years ago
All pnunn bugs reassigned to Pav, who is taking over
the imglib.
Assignee: pnunn → pavlov
Status: ASSIGNED → NEW
(Reporter)

Comment 7

18 years ago
I'm no longer seeing this bug on 2001021812.

Comment 8

18 years ago
This bug appears to be fixed in the new imaglib, checked on W2k build 
2001040304, linux build 2001040305 and mac build 2001040213
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
Verified fixed mac build 2001060408
Verified fixed w2k build 2001060409
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.