drag'n'drop of message may damage attachment

VERIFIED DUPLICATE of bug 62992

Status

MailNews Core
Backend
--
critical
VERIFIED DUPLICATE of bug 62992
17 years ago
10 years ago

People

(Reporter: Oliver Klee, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010106
BuildID:    2001010620

Sometimes a drag'n'drop of a mail with an attachment may replace an 0x0d0a in
the attachment with an 0x0d000a. This results in a crash when trying to view the
move message (see bug 53447).


Reproducible: Sometimes
Steps to Reproduce:
Drag'n'drop a message with an attachment from the inbox to any folder.

Actual Results:  The message gets moved and the attachment gets screwed up.

Expected Results:  The message gets moved without any problems.

I have a hard time trying to reproduce it right now. I don't know if it happens
only when trying to drag'n'drop from the _inbox_, and whether it makes any
difference if the message is moved or drag'n'dropped.

The mail file(s) may be fixed by replacing all 0x0d000a with 0x0d0a. To the
average user, this is not an option, thus making the moved message unviewable.
Dupe of 62992
(copy/move messages corrupts mail folder)

Oliver, this should be fixed now (fix checkedin at 12.01.2001)

*** This bug has been marked as a duplicate of 62992 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
change qa contact to myself.
verifying this bug as dup on comments below.
Status: RESOLVED → VERIFIED
QA Contact: esther → sheelar
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.