If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

textarea scrollbar thumbs have wrong cursors

VERIFIED DUPLICATE of bug 84978

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 84978
17 years ago
16 years ago

People

(Reporter: ratman, Assigned: kinmoz)

Tracking

(Depends on: 1 bug, {helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
using 2001011504 mtrunk win98.

mousing over a textarea's scrollbar thumb (*not* a native moz scrollbar widget)
causes the cursor to convert from an arrow to an i-bar text cursor.  to be more
accurate, the cursor changes from an arrow to an i-bar in the area between the
outer edge of the textarea box and the outer edge of the scrollbar thumb, then
changes back to an arrow at the pixel on the exact edge of the scrollbar thumb,
and then changes to an i-bar over the body of the thumb itself.  for the
scrollbar arrows, in contrast, the cursor is a i-beam text cursor only in the
space between the outer edges of the textarea and the scrollbar button(s).

functionality remains normal, and the thumb's state change with onclick and drag
are fine.

ideally, the cursor shouldn't change to a text cursor unless you're within the
editable part of the textarea.  at the least, a text cursor should not appear
over a scrollbar, period.


technically this depends on bug 63800 - if a native widget is used for textarea
scrollbars, then this won't be a problem.  otherwise, this needs to be fixed.
(Reporter)

Updated

17 years ago
Depends on: 63800
Keywords: correctness

Comment 1

17 years ago
->evaughan
Assignee: trudelle → evaughan
duplicate of bug 64101 or even bug 50799

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 64101 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Thanks. Verified.
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
*** Bug 50799 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Bug 64101 was marked as dup of bug 50799, and bug 50799 was
marked as dup of this. This bug should be reopened.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

17 years ago
Okay. It's kin's bug I believe.
Assignee: evaughan → kin
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

17 years ago
inheriting all platforms, p3, and future target milestone from 50799.
OS: Windows 98 → All
Priority: -- → P3
Hardware: PC → All
Target Milestone: --- → Future

Updated

17 years ago
QA Contact: jrgm → sujay

Comment 9

17 years ago
The test case from bug 61921 showing this problem with textareas may be helpful
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=20153
Proposing for Mozilla0.9 since this generates confusion.
Keywords: mozilla0.9

Comment 10

17 years ago
http://stone.undp.org/undpweb/ohr/ohrjbview.cfm?jaf_uid_c=705

Shows an example of this (thrice!).

Comment 11

17 years ago
*** Bug 70432 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
*** Bug 58729 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 71212 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 73189 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 75196 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Shouldn't someone put mostfreq on this?

Comment 17

17 years ago
Added mostfreq. This has at least 10 duplicates if you count the duplicates in 
the duplicates.
Keywords: mostfreq

Comment 18

17 years ago
*** Bug 76012 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
*** Bug 76430 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
*** Bug 81519 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 21

17 years ago
given the number of dupes, can we get this bug set to a better target milestone
than "future"?


i nominate for 1.0, at the very least.  it's not a beta blocker or anything, but
it is clearly an issue.
Keywords: helpwanted

Comment 22

17 years ago
*** Bug 82154 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
*** Bug 84072 has been marked as a duplicate of this bug. ***

Comment 24

17 years ago
*** Bug 84651 has been marked as a duplicate of this bug. ***

Comment 25

17 years ago
I also would suggest a target milestone in the near future.

Comment 26

17 years ago
Will bug 16928 be fixed by fixing this bug as well?

Comment 27

17 years ago


*** This bug has been marked as a duplicate of 84978 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 28

16 years ago
marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.