_Sort By Name_ Does Not Appear to Work on Bookmarks

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: chris_debian, Unassigned)

Tracking

4.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110506 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110506 Firefox/4.0.1

Hi,

I'm running Sabayon Linux (based on Gentoo) and in the last two weeks I have noticed that FF 4.x does not allow me to sort my Bookmark menus into alphabetical order.

Reproducible: Always

Steps to Reproduce:
1. Click on Bookmarks
2. Right-click on menu that needs sorting
3. Select _Sort By Name_


Actual Results:  
I follow the above three steps, but rather than the menu being sorted alphabetically, nothing appears to happen. In addition, some of my menu entries are no longer in the alphabetical order that they have always been in, perhaps suggesting that the sort function is using some other information to sort and display the menus.

Expected Results:  
I would expect the sub-menu results to be displayed in alphabetical order, but they are not.

uname -a
Linux aslan 2.6.37-sabayon #1 SMP Tue Mar 22 17:38:07 UTC 2011 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ AuthenticAMD GNU/Linux
(Reporter)

Updated

7 years ago
Version: unspecified → 4.0 Branch
Component: Menus → Bookmarks & History
QA Contact: menus → bookmarks
exacly on which part of the menu do you right click? Sort by name acts on the selected folder in the menu, to sort bookmarks menu you should open Show all bookmarks, right click on Bookmarks Menu and choose Sort by name.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> exacly on which part of the menu do you right click? Sort by name acts on
> the selected folder in the menu, to sort bookmarks menu you should open Show
> all bookmarks, right click on Bookmarks Menu and choose Sort by name.

I click on _Bookmarks_, then right-click on the menu I want to sort. This doesn't work, unfortunately.

This has always worked on previous versions.

Hope this helps.

Thanks,

Chris.
did you try safe mode (to exclude conflicting extensions): http://support.mozilla.com/kb/Safe+Mode

Is this menu you are trying to sort a simple bookmarks folder you created?
(Reporter)

Comment 4

7 years ago
Hi, the menu is a simple bookmarks folder.

I didn't try safe mode, as I didn't know it existed. I'll investigate and report back.

Thank you,

Chris.
(Reporter)

Comment 5

7 years ago
Restarting in Safe-Mode and trying to sort the menu alphabetically, was unsuccessful. The behaviour (or lack of) was as before.

Sorry,

Chris.
if your database (places.sqlite) is not too big please compress it and send it to me by mail (Don't attach it here since it contains your private data), specifying the name of the folder you can't sort.
Afaict sorting works fine here, but it's possible you are hitting bug 626341 (do you use Sync?)
(Reporter)

Comment 7

7 years ago
Marco,

Thanks for the quick response. I seem to have three possible files in my /home, could you tell me which one I should be looking at? Should I have three similar files?

/home/chris/.mozilla/firefox/uc1onl6z.default/places.sqlite
/home/chris/.mozilla/firefox/uq3g6doz.default/places.sqlite
/home/chris/.mozilla/eclipse/places.sqlite

Thanks,

Chris.
Strange, you have 2 profiles named "default", the eclipse one is unrelated.
Open firefox with the profile you see the bug in, and you should notice a file ".lock" in the current profile folder (Whatever of those 2 is), then I'd like to get the places.sqlite from that folder.
Or go to about:support and click the button to open the profile folder.
What Henrik said, sometimes I forget we have nice ways to do things.
(Reporter)

Comment 11

7 years ago
Thanks, guys.

I've opened the places.sqlite file and it just says:

SQLite format 3

Does that look right?

Cheers,

Chris.

Comment 12

6 years ago
Chris -> Are you still hitting this? Were you ever able to determine which profile you are running and provide your places.sqlite file via email to Marco?
(Reporter)

Comment 13

6 years ago
Hi, guys.

Thank you for your latest comment (Tim). I'm no longer using this version of the software, but can confirm that on the two boxes I use, one of which is using Sabayon Linux, I am no longer experiencing any difficulties sorting menu items.

Ii would be happy for this to be closed, if no one else has the issue.

Many thanks for the time you spend on this project.

Chris.

Comment 14

6 years ago
Thanks for reporting back. Happy New Year.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.