pointer casting problem on 64 bit machines

RESOLVED DUPLICATE of bug 20860

Status

RESOLVED DUPLICATE of bug 20860
18 years ago
14 years ago

People

(Reporter: scott, Assigned: dougt)

Tracking

Trunk
DEC
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-12 i686)
BuildID:    20010115

nsHashtable.h line 219 casts mKey to a PRUint32.  mKey is a void*.  On alpha and
other 64 systems, void* is bigger then PRUint32.  This generates a warning from
gcc: cast from pointer to integer of different size.

Line 190 contains the same thing.

Reproducible: Always
Steps to Reproduce:
just try compiling anything that includes nsHashtable.h on a 64 bit platform.

Comment 1

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Component: XPCOM → Build Config
Ever confirmed: true

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

17 years ago
over to dougt
Assignee: scc → dougt
Status: ASSIGNED → NEW
(Assignee)

Comment 3

17 years ago
isn't there a macro for pointer compares?
Already fixed -- see NS_INT32_TO_PTR and NS_PTR_TO_INT32, used now in
nsHashtable.h, fix was part of bug 20860.

/be

*** This bug has been marked as a duplicate of 20860 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.