Closed Bug 655558 Opened 9 years ago Closed 9 years ago

[Debug Windows] "xul.dll": "LINK : fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO" since 2011.05.05

Categories

(MailNews Core :: Build Config, defect, blocker)

x86
Windows Server 2003
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sgautherie, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [fixed by bug 653662])

Thunderbird and SeaMonkey Trunks:
{
LINK : fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO
make[5]: *** [xul.dll] Error 186
make[4]: *** [libs_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [default] Error 2
make: *** [build] Error 2
}

Regression timeframes:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=92d5e760e0c0&tochange=1defe29fdf3c
2 pushes by Boris, 1 push by Matt...
http://hg.mozilla.org/comm-central/rev/641d41984938
Unrelated.
Summary: [Debug Windows] "xul.dll": "LINK : fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO" since 2011.05.10 → [Debug Windows] "xul.dll": "LINK : fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO" since 2011.05.05
Depends on: 653662
After reading bug 653662, I wonder whether someone has (explicitly) confirmed that a clobber doesn't fix this? (just in case)

(Fwiw, future(!) possible solutions may be to either not (or less) compile MailNews into Xul.dll or compile with VC 2010.)

Unless triggering changeset is pinpointed and can be worked around, bug 453662 is probably the only solution ftb.
(In reply to comment #1)
> Unless triggering changeset is pinpointed and can be worked around, bug
> 453662 is probably the only solution ftb.

Err, bug 653662 !
(In reply to comment #1)
> After reading bug 653662, I wonder whether someone has (explicitly)
> confirmed that a clobber doesn't fix this? (just in case)

I did on Thunderbird soon after it started.

> (Fwiw, future(!) possible solutions may be to either not (or less) compile
> MailNews into Xul.dll or compile with VC 2010.)

Not compiling mailnews into xul.dll is likely to hurt performance. I don't see that as an option.
Fwiw, unexpectedly, this one build is green:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1304920969.1304936057.20636.gz
WINNT 5.2 comm-central-trunk leak test build on 2011/05/08 23:02:49
So is this just a matter of us adding some more code and then libxul suddenly being too big for the compiler to deal with?
(In reply to comment #5)
> So is this just a matter of us adding some more code and then libxul
> suddenly being too big for the compiler to deal with?

I don't really know, but, based on both bugs comments so far, it looks like the cause could be "just" that.

Fwiw, without having looked further, "Boris Zbarsky — Bug 614171 part 5. Inline the cheap Equals() methods on nsINodeInfo. r=sicking" caught my eye from this bug regression timeframe.

Ideally, at least ftr, someone could reapply these changesets "one by one" and check .ilk file size, until this bug triggers. Maybe on (TB) Try.
Fixed by bug 653662
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 653662]
You need to log in before you can comment on or make changes to this bug.