Remove body margin on image documents

RESOLVED FIXED

Status

()

Core
Layout: Images
--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Oz, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, [bugday-20110513] [fixed by bug 376997])

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110508 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110508 Firefox/6.0a1

Fit the HD images to width or height. Without any white space, like in safari and chrome.

Reproducible: Always
Ermm, what/where? What's the Issue?

Please try to read/understand https://developer.mozilla.org/en/Bug_writing_guidelines
Version: unspecified → Trunk
INCO without more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

6 years ago
(In reply to comment #1)
> Ermm, what/where? What's the Issue?
> 
> Please try to read/understand
> https://developer.mozilla.org/en/Bug_writing_guidelines


I know that is not an issue, I hit the submit button too fast without to set it as request or enhancement.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
but you still haven't explained what you want improved
Severity: normal → enhancement
(Reporter)

Comment 5

6 years ago
(In reply to comment #4)
> but you still haven't explained what you want improved


When you view HD images there is a white space on margins.

ex. 
http://i53.tinypic.com/102l8w0.jpg
http://i51.tinypic.com/dng3eo.jpg

Fit the image to width or height depending on image size, like in Safari and Chrome.
Oh, I see. It's not as aspect ratio thing, you're talking about the 8px of CSS margin around the image. (This presumably comes from the browser's default for |body| in html.css)

In other words, the image should extend to the edge of the window.
Summary: Fit the HD images to width or height. → Remove body margin on image documents
(Reporter)

Comment 7

6 years ago
(In reply to comment #6)
> Oh, I see. It's not as aspect ratio thing, you're talking about the 8px of
> CSS margin around the image. (This presumably comes from the browser's
> default for |body| in html.css)
> 
> In other words, the image should extend to the edge of the window.


That's right, so can be done?

Updated

6 years ago
Component: General → Layout: Images
Product: Firefox → Core
QA Contact: general → layout.images

Comment 8

6 years ago
Confirming as enhancement and it probably belongs to some of the Layout components.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is a duplicate.  Please find the original (which is, iirc, WONTFIX) and mark this duplicate.
Whiteboard: DUPEME
(Reporter)

Comment 10

6 years ago
WONTFIX?

why now? it is plain stupid to have that white space on margins.
The bug, if it's WONTFIX, has an explanation of why.

Comment 12

6 years ago
Seems to be this one.
Status: NEW → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 136002
No, that's not it...
Status: RESOLVED → REOPENED
Keywords: uiwanted
Resolution: DUPLICATE → ---
Though probably dependent.
Depends on: 136002

Updated

6 years ago
Whiteboard: DUPEME → DUPEME, [bugday-20110513]
(Reporter)

Comment 15

6 years ago
This is not a bug!  It's a request/enhancement

When you view HD images there is a white space on margins.

ex. 
http://i53.tinypic.com/102l8w0.jpg
http://i51.tinypic.com/dng3eo.jpg

Fit the image to width or height depending on image size, like in Safari and Chrome.
(In reply to comment #7)

> That's right, so can be done?

It's a legitimate request, but I'd like to see the rationale / previous thinking in the aforementioned existing bug (if it can be found).
(Reporter)

Comment 17

6 years ago
(In reply to comment #16)
> (In reply to comment #7)
> 
> > That's right, so can be done?
> 
> It's a legitimate request, but I'd like to see the rationale / previous
> thinking in the aforementioned existing bug (if it can be found).


https://bugzilla.mozilla.org/show_bug.cgi?id=136002

this one?
(Reporter)

Comment 18

6 years ago
(In reply to comment #15)
> This is not a bug!  It's a request/enhancement
> 
> When you view HD images there is a white space on margins.
> 
> ex. 
> http://i53.tinypic.com/102l8w0.jpg
> http://i51.tinypic.com/dng3eo.jpg
> 
> Fit the image to width or height depending on image size, like in Safari and
> Chrome.



any news on this?
Depends on: 376997
(Reporter)

Comment 19

6 years ago
(In reply to comment #16)
> (In reply to comment #7)
> 
> > That's right, so can be done?
> 
> It's a legitimate request, but I'd like to see the rationale / previous
> thinking in the aforementioned existing bug (if it can be found).

I don't get it what issue can be if you fit the HD image to the browser width/height depending on the image resolution.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: DUPEME, [bugday-20110513] → DUPEME, [bugday-20110513] [fixed by bug 376997]
You need to log in before you can comment on or make changes to this bug.