CERTAIN .jpg files do not show up in the background with CSS formatting commands.

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Gimmel Yod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

JPG files can be created with slightly different color formatting techniques.  I notice that certain FireFox browsers do not properly display CSS backgrounds w. some of these files --those encoded the most efficiently with 4:2:2 compression.  What other forms of compression may fail is anyone's guess.

Reproducible: Always

Steps to Reproduce:
1. visit http://g0ys.org/certifiable.htm
2.
3.

Actual Results:  
No background displayed in certain Firefox browsers.

Expected Results:  
Background should be displayed.

See the HTML code for specific file info.
You mean http://g0ys.org/images/G0YSorg_Page_Background.jpg, I assume?

Also, "certain" is too vague to be helpful; please do tell in *which* Firefox browsers you see the bug.
Severity: major → normal
Component: File Handling → ImageLib
Product: Firefox → Core
QA Contact: file.handling → imagelib
(In reply to comment #1)
> You mean http://g0ys.org/images/G0YSorg_Page_Background.jpg, I assume?

FWIW, that image is blank for me in Firefox 3.0, 3.5, 3.6. 4.0, and Chromium 11.

When I open it in gimp, I get the message
> Sampling factors too large for interleaved scan

When I open it in Ubuntu's default image viewer, I get the message
> Error interpreting JPEG image file (Sampling factors too large for interleaved scan)

Looks like it's just a busted jpeg?
The image is working for me in 9.0a2. This could be because the image the URL changed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.