don't open a link from "window.open()"ed window

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: hATrayflood, Unassigned)

Tracking

4.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

In a only no-menu(window.open()) window, I click link with target="_blank".
firefox open a new window, but URL not loaded. and tabs restored.

(ja)
window.open()で開いたメニューなしウィンドウだけの状態で、target="_blank"のリンクをクリックすると、
新規ウィンドウは開くが目的のURLは開かず、以前の開いていたページが復元された状態になる。


Reproducible: Always

Steps to Reproduce:
1. (Re)start firefox 4.
2. open http://tmtm.org/tmp/fx4bug.html
3. click "open".
4. close parent window.
5. click "mozilla".
(Reporter)

Updated

7 years ago
Version: unspecified → 4.0 Branch
Not sure I understand this report well enough. Can you please give further information and expected vs. current results?
This bug is very similar and it seems that it will be solved if the bug 452332 is solved too.

The only difference between current bug and the bug 452332 is that the parent window (the one that generates the new window) get closed at current bug.
 
The common behaviour in both bugs is that when you open a new tab, at a new generated window by javascript method window.open(), the new tab will open at the parent window and not at the generated one.
For steps to reproduce look at the comments of both bugs (655629 and 452332)
(In reply to comment #1)
> Not sure I understand this report well enough. Can you please give further
> information and expected vs. current results?

Current results:
New tab at the generated window opens at the parent window instead of the generated one.
Expected result:
New tab at the generated window opens at the generated window and not at the parent one.

Comment 4

7 years ago
Reporter, does the issue is still reproducing?
(In reply to comment #4)
> Reporter, does the issue is still reproducing?

I am not the reporter but at firefox 5 (Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0) the problem is not reproducible any more.
Now the new tab opens at a new window and not at the old one that was closed.
As I mentioned at my previous comment the bug has been resolved, now the closed window isn't restored, so the tab opens at a new (parent) window.

I want just to add a reference on bug 626365 at which is described what happens when if the parent window is not closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.