Border is redrawn improperly when fieldset size is increased

RESOLVED FIXED in mozilla1.1alpha

Status

()

Core
Layout
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: Antti Näyhä, Assigned: John Keiser (jkeiser))

Tracking

({html4, testcase})

Trunk
mozilla1.1alpha
html4, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Overview description:
  Fieldset border is improperly redrawn when the fieldset's size is increased
  dynamically.

Steps to reproduce:
  1) View the attachment.
  2) Push the button to reveal the hidden paragraph.

Actual results:
  The new, expanded border is drawn, but the previous border is not completely
  cleared.  Result: an ugly extra horizontal line in the right border.

Expected results:
  Nice, clean redraw.  See the attachment on eg. IE 5.5.

Build date & platform:
  2001-01-15-08 (Linux i686)

Additional builds and platforms:
  Mozilla 0.7 (Win32)
(Reporter)

Comment 1

17 years ago
Created attachment 22647 [details]
A resizing fieldset test
(Reporter)

Comment 2

17 years ago
Adding 'html4' keyword.
Keywords: html4

Comment 3

17 years ago
This is an calculation error caused by the border/padding value(s) in the CSS.
If you use something like this:

  fieldset {
  	display : block;
  	border : 1px solid black;
  	padding : 0px;
	padding-top : 4px;
	padding-bottom : 4px;
  	margin-left : 2px;
  	margin-right : 2px;
  }

then you don't see that problem! If you set border to 2px then you will see 1px
at the right! By increasing the border/padding value(s) the problem get worse,
by that amount of pixels. If you resize the window, the problem is solved. So
this is only a problem after the first rendering. It's a bug, that's for sure!

Comment 4

17 years ago
Created attachment 22650 [details]
Example of the border/padding issue

Comment 5

17 years ago
b.t.w. that line around fieldset in the default HTML.CSS should be 1px thick and
not 2px because that's ugly!

Comment 6

17 years ago
H-J wrote:
> b.t.w. that line around fieldset in the default HTML.CSS should be 1px thick and
> not 2px because that's ugly!
Actually I would have thought 2px groove threedface would be nicer (c.f.
http://lxr.mozilla.org/seamonkey/source/themes/classic/global/win/box.css)
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian

Comment 8

17 years ago
Reassigned to Layout/attinasi.  I guess there is problem with the reflow of the 
nsFieldSetFrame. It doesn't happen with DIVs for instance (see my new testcase).
Assignee: pierre → attinasi
Component: Style System → Layout

Comment 9

17 years ago
Created attachment 45492 [details]
testcase fieldset/div

Comment 10

17 years ago
Looks more like an invalidation problem, because hiding and re-exposing the
fieldset frame makes it paint OK. CC'ing rods.
Keywords: testcase

Updated

17 years ago
Target Milestone: --- → mozilla1.1
(Assignee)

Comment 11

16 years ago
The fix to bug 124507 can be applied to this as well.  Taking.
Assignee: attinasi → jkeiser
Depends on: 124507
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 12

16 years ago
WFM 2002050806/branch/Win2K
(Assignee)

Comment 13

16 years ago
It is passing strange, but this WFM Linux 2002050910 too.  I don't see any fixes
to nsFieldsetFrame, but clear as day the problem is fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.