When add-ons manager is the only opened tab, there is no way to get navigation bar at this tab

RESOLVED FIXED in Firefox 28

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: fredy, Unassigned)

Tracking

4.0 Branch
Firefox 28
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 752434)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

I open firefox and I have only one blank page tab, then open add-ons manager to change some options or addons or plugins etc. When I finished the changes, with restart or not, and I want to browse a web page, there is not a way to get navigation bar or a blank page tab to type a web page address. The only frustrating way is to open a new tab and then close the add-ons manager and starting browsing at the new tab.

My suggestions to solve this are:

1. If the only opened tab is a blank tab, the add-ons manager will open at a new tab.
2. Adding a close button at the add-ons manager which will close add-ons manager tab and if it is the only opened tab will substituting this with a blank page tab or open a new tab.
3. A similar solution to the second is to preserve the X button at the tab when this tab is the add-ons manager and if it is pressed, it will close the add-ons manager and open a new tab.

I think the second solution is less confusing and more clean than the other two. The first one oppose to the known idea at which if there is a blank page then the add-ons manager will open there. The second one oppose to users which have customized firefox to close when click on the last tab's X button.

Reproducible: Always

Steps to Reproduce:
1. Make a  firefox window to have only one blank page tab opened.
2. Try with one click to get a tab with navigation bar in which you can browse a site

Actual Results:  
There is not a way to do this.

Expected Results:  
A button that allows you to get a tab with navigation bar with one click.

This "bug" happens usually when you have the option of blank page when the firefox starts. However it can be also produced when someone open a new tab and close all other tabs and then follow the steps to reproduce.
Correcting the reproduce steps

Steps to Reproduce:
1. Make a  firefox window to have only one blank page tab opened.
2. Open add-ons manager.
3. Try with one click to get a tab with navigation bar in which you can browse a site
(In reply to comment #0)
> changes, with restart or not, and I want to browse a web page, there is not
> a way to get navigation bar or a blank page tab to type a web page address.
> The only frustrating way is to open a new tab and then close the add-ons
> manager and starting browsing at the new tab.

We hide the location bar for in-content pages. The same will apply to upcoming redesigns for the download manager, preferences, or others. The keyboard shortcut is still functional, which means you can hit Cmd/Ctrl+L to enter a new URL. Otherwise hit Cmd/Ctrl+T or click the '+' toolbar button to open a new tab.

> Expected Results:  
> A button that allows you to get a tab with navigation bar with one click.

Which is the new tab toolbar button. Isn't it?
Version: unspecified → 4.0 Branch
(In reply to comment #2)
> (In reply to comment #0)
> > changes, with restart or not, and I want to browse a web page, there is not
> > a way to get navigation bar or a blank page tab to type a web page address.
> > The only frustrating way is to open a new tab and then close the add-ons
> > manager and starting browsing at the new tab.
> 
> We hide the location bar for in-content pages. The same will apply to
> upcoming redesigns for the download manager, preferences, or others. The
> keyboard shortcut is still functional, which means you can hit Cmd/Ctrl+L to
> enter a new URL. Otherwise hit Cmd/Ctrl+T or click the '+' toolbar button to
> open a new tab.
> 
ok these shortcuts work fine, thx
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
I would still like to get feedback from UX before we close out this bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: uiwanted
Resolution: INVALID → ---
The easiest workaround would be to just open a new tab if you hit Ctrl-L in this window. Longer-term, we need to get rid of the old-style URL dialog and just fold down the URL bar instead.
Keywords: uiwanted

Updated

4 years ago
Duplicate of this bug: 727498
This bug has been solved with the new Australis UI. Addons manager doesn't hide navigation bar anymore, so it behaves as an ordinary tab.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Depends on: 752434
Whiteboard: fixed by bug 752434
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.