Flash 10.3 crashes when switching into fullscreen mode [@ QD@0x4e76 ]

VERIFIED FIXED

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: whimboo, Assigned: jet)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110508 Firefox/6.0a1

Since I have installed the preview version of Flash 10.3, I always experience a crash when trying to switch into full-screen mode for an embedded Flash movie on Facebook. It happens across Firefox 4.0.x, Aurora, and Nightly builds. Firefox 3.6 doesn't seem to be affected.

As a side-effect of the crash the dock and the main menu are also invisible from that moment on when Firefox is the front-most application.

Crash report: bp-f8142b0f-ed99-442d-ba3b-b6cb12110509

0 	QD 	QD@0x4e76 	
1 	QD 	QD@0x6725 	
2 	FlashPlayer-10.6 	FlashPlayer-10.6@0x4d0094 	
3 	FlashPlayer-10.6 	FlashPlayer-10.6@0x4d3920 	
4 	FlashPlayer-10.6 	FlashPlayer-10.6@0x457bf0 	
5 	FlashPlayer-10.6 	FlashPlayer-10.6@0x362128 	
6 	FlashPlayer-10.6 	FlashPlayer-10.6@0x4d237a 	
7 	FlashPlayer-10.6 	FlashPlayer-10.6@0x3a55a2 	
8 	FlashPlayer-10.6 	FlashPlayer-10.6@0x1d98c5 	
9 		@0x19ea038e
Moving over to core plugins for now, since it is a regression between Firefox 3.6 and Firefox 4.0. I will narrow down the regression range.
Component: Flash (Adobe) → Plug-ins
Keywords: regression, regressionwindow-wanted
Product: Plugins → Core
QA Contact: adobe-flash → plugins
Version: unspecified → 2.0 Branch

Comment 2

7 years ago
Does this also happen with youtube and other sites that have fullscreen, or only facebook?

The regression range is likely to be "we turned OOPP on", which isn't that helpful, but I guess we can still check to make sure.
For now it's only happening with the embedding of Flash movies on Facebook. I'm not able to reproduce it with the default embedding (iframes).

The crash started with devpreview v4 of Firefox 4.0. I will narrow it down even more for a better range.

Which pref I would have to turn off on trunk to not let Flash use IPC for 64 bit builds? It doesn't seem to be 'dom.ipc.plugins.enabled.x86_64' because it completely switches off Flash. And with 'dom.ipc.plugins.enabled.i386.flash player.plugin' turned off it is still crashing.

Comment 4

7 years ago
You cannot run Flash in-process on 64-bit builds.
The crash started to happen between 10040503 and 10040603.

PASS: http://hg.mozilla.org/mozilla-central/rev/c4df407008b5
FAIL: http://hg.mozilla.org/mozilla-central/rev/523d0f8e0926

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c4df407008b5&tochange=523d0f8e0926

I will have to figure out the right testcase for it.
Keywords: regressionwindow-wanted → testcase-wanted
I have downgraded Flash to 10.2 and everything works pretty well. There is no crash happening anymore with any of the embedded videos on a Facebook's wall. This seems to be a regression in the upcoming Flash 10.3.
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: 2.0 Branch → 10.3
I'm not able to create a local testcase. Seems like there is some JS interaction on the website itself which doesn't work with a downloaded page.
Adobe has now released Flash 10.3. After its installation I have retested full screen on Flash movies on Facebook and there is no crash anymore. Seems like it has been fixed since 10.3RC1.

Can we get Adobe to confirm that, or how do we handle that bug now?
(Assignee)

Comment 9

7 years ago
Yes, we fixed several fullscreen & video bugs in the 10.3 release.
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Assignee: nobody → jet
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Thanks. Marking as verified fixed then.
Status: RESOLVED → VERIFIED
Keywords: testcase-wanted
Crash Signature: [@ QD@0x4e76 ]

Comment 11

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.3 → unspecified
You need to log in before you can comment on or make changes to this bug.