Firefox does not open in more than one virtual desktop of sysinternals' Desktops utility

RESOLVED INVALID

Status

()

Firefox
Shell Integration
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: lothar_, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Firefox does not open in more than one virtual desktop of sysinternals' Desktops utility
sysinternals' Desktops utility creates 4 virtual desktops on a Windows machine, available here: http://technet.microsoft.com/en-us/sysinternals/cc817881 

when Firefox is open in one such virtual desktop, it fails to open in another, giving the message "Firefox is already running, but is not responding. to open a new window, you must first close the existing Firefox process or restart your system." 


Reproducible: Always

Steps to Reproduce:
1. install sysinternals' Desktops.
2. run Firefox.
3. switch to another virtual desktop.
4. attempt to run Firefox.

Actual Results:  
Firefox fails to run, giving the message "Firefox is already running, but is not responding. to open a new window, you must first close the existing Firefox process or restart your system." 

Expected Results:  
Firefox should run as well in a different virtual desktop as in the original virtual desktop.
It's by design that you can only run one instance of Firefox. You can create different firefox profiles and use the -no-remote commandline switch to run more than one instance
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
In reply to comment #1)
1) it is not true that one can not run more than one instance of Firefox.
within one virtual desktop, one can run any number of them,
without command line options, as long as Firefox is not running in any other virtual desktop.

2) it is not clear why running a new Firefox from a different virtual desktop
should be treated differently than running a new Firefox from
the current virtual desktop.
>1) it is not true that one can not run more than one instance of Firefox.
You always have only one instance. What you usually get is one instance with multiple windows. That is the reason why all Firefox windows disappear if Firefox crashes because the single Firefox.exe crashed.

Clicking the Firefox Icon on the desktop again doesn't open a new instance. The new started Firefox.exe sends a message to the first Firefox.exe to open a new window and after that it closes itself. Your tool seems to isolating the first Firefox.exe process. The new started Firefox.exe can not send a message to the first process to open a new window. In that case it tries to start and you would have 2 running Firefox.exe processes at the same time. 
The loading of the Firefox user profile fails in that case because it's already in use by the first Firefox.exe process. 2 independent processes that write to one single Firefox userprofile would destroy the profile. The error message tells you exactly this: There is already a running Firefox.exe
You need to log in before you can comment on or make changes to this bug.