Debugging onresize event with Firebug makes the window blank

RESOLVED DUPLICATE of bug 582613

Status

DevTools
General
RESOLVED DUPLICATE of bug 582613
7 years ago
a month ago

People

(Reporter: Gustavo Henke, Unassigned)

Tracking

4.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When I try to debug a onresize event for "window" fired by jQuery with Firebug, the Firefox window gets blank.
No tabs, no address bar, nothing appears, only the top bar, where the website title appears. 

If I press F5 to refresh the page, everything gets OK again.

I'm using Firefox 4.0.1 in Windows XP SP3 with the classic theme right now. Will try with another OSs when get back home.

Note: I don't know if that's buggy without jQuery too. Will try soon to see what happens.

Reproducible: Always

Steps to Reproduce:
Steps to reproduce:
1. Have anything in the onresize event set for "window"
2. In Firebug, put a breakpoint inside the function
3. Resize the window
4. Note that the window will get blank, just like I've described above.
(Reporter)

Comment 1

7 years ago
Created attachment 531038 [details]
The blank window after debugging onresize for "window"

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 2

7 years ago
You don't need jQuery to reproduce this bug. This simple HTML code will suffice:

<body onresize="alert('test');"></body>

Resize this and you get a black window (and no alert). [F5] gets the window contents back, but Firefox tends to be unstable after this has happened.

Comment 3

7 years ago
adding Honza to this bug... Honza: any idea if this bug is in Firebug or Firefox?
(Reporter)

Comment 4

7 years ago
I've just tested using the example by #2 in safe mode. That screen appeared again.

Comment 5

7 years ago
In safe mode Firebug is disabled so I don't see how you could put a breakpoint anywhere.
This is a Firefox bug:

Boris says:
--
Windows handles resizes in bizarre ways; it spins up a second modal event loop while resizing....  So I can certainly see something like this happening.  Please file a bug in bugzilla?  This looks bad.
---

I am marking as duplicate of bug 582613
Honza
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 582613

Comment 7

7 years ago
This is not a Windows-only phenomenon; please see my comment under bug 582613.

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.